Std PPPoE work, but PPPoE with FreeRadius doesn't



  • Hi, first, THANKS a MILLION for such a great support site for such a great product.

    Right, its 1.0-RELEASE, with JUST FreeRadius also installed.
    Normal PPPoE connections work, but when I change to use the Radius Server, it doesnt connect.
    I suspect its a single setting, but what am I missing?

    PLEASE somebody - where is my mistake !!!



  • set freeradius up to use the lan interface
    set a client up on freeradius with te lan interface ip as clientip
    and a secrect

    on the pppoe server setup page use the lan interface ipadress as radius server ip
    and the freeradius client secret



  • Hi Jeroen

    thanks for the reply, I had tried this previously, but what I get is the following … It "finds" a server, and goes the the "Verifying Username and Password" box, then times out with a 718 error: The remote computer did not respond in a timely manner.

    any other suggestions ?

    Mike



  • dit you add the user and password you want to use for youre pc to the freeradius user tab ?



  • yes I did, but I have now noticed that the FreeRadius service is NOT started  :'(

    Also, if I click on Start, the page reloads, saying started, but the service stays with the STOPPED icon and it still does not work.

    I think I need to read more help pages !!!



  • can you log in to the box via consule or ssh
    and go to the shell (8)

    enter

    radiusd -X

    watt error gives freeradius now ?



  • same issues here, here is the output:

    
    # radiusd -X
    Starting - reading configuration files ...
    reread_config:  reading radiusd.conf
    Config:   including file: /usr/local/etc/raddb/proxy.conf
    Config:   including file: /usr/local/etc/raddb/clients.conf
    Config:   including file: /usr/local/etc/raddb/snmp.conf
    Config:   including file: /usr/local/etc/raddb/eap.conf
    Config:   including file: /usr/local/etc/raddb/sql.conf
     main: prefix = "/usr/local"
     main: localstatedir = "/var"
     main: logdir = "/var/log"
     main: libdir = "/usr/local/lib"
     main: radacctdir = "/var/log/radacct"
     main: hostname_lookups = no
     main: max_request_time = 30
     main: cleanup_delay = 5
     main: max_requests = 1024
     main: delete_blocked_requests = 0
     main: port = 0
     main: allow_core_dumps = no
     main: log_stripped_names = no
     main: log_file = "/var/log/radius.log"
     main: log_auth = no
     main: log_auth_badpass = no
     main: log_auth_goodpass = no
     main: pidfile = "/var/run/radiusd/radiusd.pid"
     main: bind_address = 192.168.11.11 IP address [192.168.11.11]
     main: user = "(null)"
     main: group = "(null)"
     main: usercollide = no
     main: lower_user = "no"
     main: lower_pass = "no"
     main: nospace_user = "no"
     main: nospace_pass = "no"
     main: checkrad = "/usr/local/sbin/checkrad"
     main: proxy_requests = yes
     proxy: retry_delay = 5
     proxy: retry_count = 3
     proxy: synchronous = no
     proxy: default_fallback = yes
     proxy: dead_time = 120
     proxy: post_proxy_authorize = no
     proxy: wake_all_if_all_dead = no
     security: max_attributes = 200
     security: reject_delay = 1
     security: status_server = no
     main: debug_level = 0
    read_config_files:  reading dictionary
    read_config_files:  reading naslist
    Using deprecated naslist file.  Support for this will go away soon.
    read_config_files:  reading clients
    read_config_files:  reading realms
    radiusd:  entering modules setup
    Module: Library search path is /usr/local/lib
    radiusd.conf[226] Failed to link to module 'rlm_exec': /usr/local/lib/rlm_exec.a: invalid file format
    #
    
    

    any info how to correct this issue? i really need radius server…



  • @_Adik_:

    radiusd.conf[226] Failed to link to module 'rlm_exec': /usr/local/lib/rlm_exec.a: invalid file format

    That's mighty strange..



  • forgot to mentoin that im using 1.0.1 version freshly installed in vmware… any other info needed?

    btw, i have one more question, is it possible to do 1:1 mapping using ip from pppoe client?


Log in to reply