M1n1wall - Can't connect via serial w/ putty



  • Just got a m1n1wall for our small business network today.

    I accidentally swapped the LAN and OPT1 interfaces under "Assign Interfaces".  Of course at this point I cannot connect to the web interface since the interfaces are swapped.  I attempted to swap the ethernet ports but still cannot connect.

    I figured I'd just login to the machine via Putty and reassign the interfaces there.

    I followed the quickstart guide for the m1n1wall and used putty to connect via COM1 at 38400.  But the terminal window just sits there.  No indications of connecting.  I also tried 9600 baud.  Same result.  Am I missing something?



  • are you using a null modem/crossover cable?

    Roy…



  • Yup, a female to female serial cable.



  • Also I've tried power cycling the m1n1wall several times with no luck in the serial/terminal window.



  • female to male does not mean it's a null modem cable.  it could also be a straight cable.

    Roy…



  • if you have an Ohm meter or a continuity tester check that pin 2 on one end goes to pin 3 on the other end and pin 3 to pin 2.

    Roy…



  • Ugh okay… I guess I thought 9 pin serial cable was what was necessary :-/

    Can you link me to an example of exactly what I need?  Like from Amazon or Newegg or something?



  • http://www.monoprice.com/products/product.asp?c_id=102&cp_id=10212&cs_id=1021205&p_id=477&seq=1&format=2

    Or just re-flash your CF card.  Also, you might want to use 2.0 Beta unless it's a mission critical firewall.

    Roy…



  • Thanks for the advice on the Null Modem Cable.  I guess I was just using a simple serial cable before.  The Null Modem Cable did the trick.

    So I was able to successfully hook up to it via putty.

    Now, I'm trying to connect to it using minicom on a linux box but I'm having a hard time.  This is what I've got:

    Serial Device: /dev/ttyS1
    Bps/Par/Bits: 9600 8N1
    Hardware Flow Control: No
    Software Flow Control: No

    I'm not getting anything to show up on the screen.  9600 8N1 is the same as what I used with putty.  I've never used minicom before today though, so I'm sure there is something I'm doing wrong.

    And FYI, its important that I'm able to hook up to the Netgate with minicom (or any other linux-based terminal program) because the firewall will be sitting in an all linux server environment.  No Windoze servers with putty to fall back on.

    Can anyone who has successfully connected to a Netgate via minicom chime in?  I'd appreciate it!



  • I figured it out.  Had to use /dev/ttys0 instead.


Log in to reply