[SOLVED] Stuck at 100% CPU usage (idlepoll)



  • 2.0-BETA4 (i386)
    built on Mon Dec 6 08:20:16 EST 2010

    Dashboard displays 100 CPU usage.

    System activities show this:

    last pid:  5505;  load averages:  1.35,  1.17,  1.06  up 0+01:57:45    23:00:00
    105 processes: 3 running, 86 sleeping, 16 waiting
    
    Mem: 37M Active, 15M Inact, 45M Wired, 204K Cache, 34M Buf, 859M Free
    Swap: 2048M Total, 2048M Free
    
      PID USERNAME  PRI NICE   SIZE    RES STATE    TIME   WCPU COMMAND
       20 root      171 ki-6     0K     8K RUN    109:28 91.16% idlepoll
     3954 root       58    0 54648K 18268K piperd   0:05  0.98% php
     3772 root       76    0 54648K 21564K accept   0:08  0.59% php
       12 root      -44    -     0K   128K WAIT     3:34  0.00% {swi1: netisr 0}
        0 root       76    0     0K    96K sched    0:56  0.00% {swapper}
       12 root      -32    -     0K   128K WAIT     0:25  0.00% {swi4: clock}
       11 root      171 ki31     0K     8K RUN      0:08  0.00% idle
    36744 root       44    0  3376K  1104K select   0:04  0.00% powerd
    34845 root       76   20  3656K  1536K wait     0:04  0.00% sh
       12 root      -68    -     0K   128K WAIT     0:02  0.00% {irq19: em3 ath0+}
    62239 root       44    0  6556K  4816K kqread   0:02  0.00% lighttpd
        0 root      -68    0     0K    96K -        0:01  0.00% {ath0 taskq}
       23 root       44    -     0K     8K syncer   0:01  0.00% syncer
        0 root      -68    0     0K    96K -        0:01  0.00% {em0 taskq}
      304 root       76    0 54648K 16740K accept   0:01  0.00% php
        3 root       -8    -     0K     8K -        0:01  0.00% g_up
    17158 nobody     44    0  5552K  2416K select   0:01  0.00% dnsmasq
       14 root      -16    -     0K     8K -        0:00  0.00% yarrow
    

    Any hint on why I see this?
    Thanks



  • You probably have device polling enabled. To change, in GUI, System -> Advanced, click on Networking tab and uncheck the box Enable Device Polling.



  • You're right, I have activated this features since I thought it was a good idea.
    Still, is device polling a good thing to set in a normal use of PFsense?

    Thanks


  • Rebel Alliance Developer Netgate

    It really depends on your throughput levels and hardware.

    In some cases, if your hardware is overloaded with interrupts but can otherwise handle more load, it can help. For most people that is not the case as they hit other bottlenecks before maxing out any interrupt capabilities.

    Polling works by using the idle cpu time to poll the hardware for data. So it really isn't maxing out your CPU full time, it will give up cycles if they can be spared. It's just how the cpu usage is counted doesn't factor that in.



  • Looks like you're using Intel GBe nics.  Pretty much the best available.  I doubt you need to enable polling.  Besides, the idle polling will probably interfere with PowerD functioning as it should be.



  • Thank you very much for those advices!. As a comment says I use intel gb nic adapter so I guess it is safe to disable the device polling.

    Thanks again guys.
    Romain


Log in to reply