PppoE WAN Problem Authentication?



  • Hello,

    I have setup pfsense successfully. Seems to be running fine.
    Have a problem, using pppoe to dial to my ISP.

    I'm using a DSL modem in bridge mode, the modem connects fine, using annother router.

    Using pfsense, and providing the same correct credentials as the other router, pfsens fails to connect with the follow log:

    Dec 7 14:12:03 mpd: MRU 1492
    Dec 7 14:12:03 mpd: AUTHPROTO PAP
    Dec 7 14:12:03 mpd: MAGICNUM 07c082c3
    Dec 7 14:12:03 mpd: MRU 1492
    Dec 7 14:12:03 mpd: AUTHPROTO PAP
    Dec 7 14:12:03 mpd: MAGICNUM 07c082c3
    Dec 7 14:12:03 mpd: MRU 1492
    Dec 7 14:12:03 mpd: MAGICNUM 9ca4d353
    Dec 7 14:12:08 mpd: MESG: user unknown
    Dec 7 14:12:13 mpd: MRU 1492
    Dec 7 14:12:13 mpd: MAGICNUM 9b98ad19
    Dec 7 14:12:13 mpd: MRU 1492
    Dec 7 14:12:13 mpd: AUTHPROTO PAP
    Dec 7 14:12:13 mpd: MAGICNUM 1aeb12ec
    Dec 7 14:12:13 mpd: MRU 1492
    Dec 7 14:12:13 mpd: AUTHPROTO PAP
    Dec 7 14:12:13 mpd: MAGICNUM 1aeb12ec
    Dec 7 14:12:13 mpd: MRU 1492
    Dec 7 14:12:13 mpd: MAGICNUM 9b98ad19
    Dec 7 14:12:18 mpd: MESG: user unknown
    Dec 7 14:12:24 mpd: MRU 1492
    Dec 7 14:12:24 mpd: MAGICNUM 98d9ec17
    Dec 7 14:12:24 mpd: MRU 1492
    Dec 7 14:12:24 mpd: AUTHPROTO PAP
    Dec 7 14:12:24 mpd: MAGICNUM 402a9c5f

    As i understund, the problem is wrong credentials? ( mpd: MESG: user unknown)

    I'd like to say that the username and password contain characters such us "@" and ".".
    doing a cat at /var/etc/mpd.conf I can see that the correct credentials are in the configuration, that i have setup via the webConfigurator:
    set bundle authname "xxxxx@xxxxxx.com"
    set bundle password "xxx@xxxxx"

    Any ideas on what is the problem?
    I'd like to state, that another router, using the same DSL modem in bridge mode, connects fine, using the same credentials.



  • Some more interesting info:

    This is the log from the other router that connects successfully

    16:16:34 pppd pppd 2.4.4 started by root, uid 0
    16:16:34 pppd Using interface ppp0
    16:16:34 pppd Connect: ppp0 <--> /dev/ttyp0
    16:16:35 pppoe PPP session is 13507 (0x34c3)
    16:16:36 pppd PAP authentication succeeded
    16:16:36 pppd kernel does not support PPP filtering
    

    I can see that it's using PAP authentication.

    At pfsense /var/etc/mpd.conf  the following statements are enabled:

    pppoe:
    	new -i ng0 pppoe pppoe
    	set iface route default
    	set iface disable on-demand
    	set iface idle 0
    	set iface up-script /usr/local/sbin/ppp-linkup
    	set bundle disable multilink
    	set bundle authname "xxxxx@xxxxxx.com"
            set bundle password "xxx@xxxxx"
    	set bundle no noretry
    	set link keep-alive 10 60
    	set link max-redial 0
    	set link no acfcomp protocomp
    	set link disable pap chap
    	set link accept chap
    	set link mtu 1492
    	set ipcp yes vjcomp
    	set ipcp ranges 0.0.0.0/0 0.0.0.0/0
    	set ipcp enable req-pri-dns
    	set ipcp enable req-sec-dns
    	open iface
    

    I can see the "set link accept chap"
    So is the problem related to the type of the authentication used?
    Should i change to pap in pfsense?


Log in to reply