XMLRPC sync issues on Dec 9 05:12:59 build



  • Hi!

    I recently upgraded my embedded ALIX redundant setup from a mid november build to the latest 2.0 beta4 (Dec 9 05:12:59) build.

    This resulted in some new and interesting problems.
    Both nodes decided they should become master on the CARP virtual IP's and the synchronization between the nodes stopped working.

    I reset both nodes to factory defaults and reconfigured one node as primary firewall.
    The interfaces are configured correctly and the firewall rules are set to any-any on the sync interface.
    Then tried to have the firewall sync the configuration to the second firewall, but XMLRPC sync is not possible:

    Dec 9 22:36:26 php: : The other member is on older version of . Sync will not be done to prevent problems!
    Dec 9 22:36:26 php: : New alert found: An error code was received while attempting XMLRPC sync with username admin http://172.17.1.251:80 - Code 3: Incorrect parameters passed to method: Signature permits 1 parameters but the request had 2
    Dec 9 22:36:26 php: : An error code was received while attempting XMLRPC sync with username admin http://172.17.1.251:80 - Code 3: Incorrect parameters passed to method: Signature permits 1 parameters but the request had 2
    Dec 9 22:36:26 php: : New alert found: An error code was received while attempting XMLRPC sync with username admin http://172.17.1.251:80 - Code 3: Incorrect parameters passed to method: Signature permits 1 parameters but the request had 2
    Dec 9 22:36:26 php: : An error code was received while attempting XMLRPC sync with username admin http://172.17.1.251:80 - Code 3: Incorrect parameters passed to method: Signature permits 1 parameters but the request had 2

    The passwords have been double-checked and moving to https is no solution.
    There is traffic going back and forth between the nodes on the sync interface and the traffic is not blocked.

    Has the XMLRPC library perhaps been updated recently?

    If you need more detailed info, please let me know.



  • Please upgrade to newer snapshots.
    I just fixed it.



  • OK. Installed theDec 10 09:12:10 build.

    The error code is one down!  :)

    Dec 10 23:03:41 php: : The other member is on older version of . Sync will not be done to prevent problems!
    Dec 10 23:03:40 php: : New alert found: An error code was received while attempting XMLRPC sync with username admin http://172.17.1.251:80 - Code 2: Invalid return payload: enable debugging to examine incoming payload
    Dec 10 23:03:40 php: : An error code was received while attempting XMLRPC sync with username admin http://172.17.1.251:80 - Code 2: Invalid return payload: enable debugging to examine incoming payload
    Dec 10 23:03:40 php: : New alert found: An error code was received while attempting XMLRPC sync with username admin http://172.17.1.251:80 - Code 2: Invalid return payload: enable debugging to examine incoming payload
    Dec 10 23:03:40 php: : An error code was received while attempting XMLRPC sync with username admin http://172.17.1.251:80 - Code 2: Invalid return payload: enable debugging to examine incoming payload

    Can you tell me how to turn on debugging?





  • OK. I will check and update redmine with feedback.


Log in to reply