Fatal Error on vpn.inc



  • I tried adding another vpn tunnel, when i hit 'apply changes'  this is what happened:

    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 21907670 bytes) in /etc/inc/vpn.inc on line 291

    This is on version 1.2.3-Release with multiple gateways, multiple BGP peers (full route announcement) and multiple non NAT'ed LAN using VLAN trunking. Platform is x86 class pentium with 1GB of memory and IDE flash drive.

    All tunnels are site-to-site, PSK, AES - SHA1 and DH2 for both stages.

    The first tunnel I added was using the 'WAN' interface IP , the second that started to show the error above was using my other upstream provider interface (WAN2). Both interface are BGP'd. Both tunnels are going to the same far end gateway / LAN but to separate subnets on the local router.

    If I disable all tunnels, apply changes, then enable the secondary upstream tunnel (WAN2) - everything works fine. If after that I try to enable the tunnel using my WAN interface - I get that error above. If I start over again, all tunnels disabled and try to enable the WAN interface tunnel first - i still get that error.

    Hopefully someone can shed a light on this. OpenVPN is not an option as the far end router does not support it. Thanks.


  • Rebel Alliance Developer Netgate

    I think someone had committed a fix for this a few days ago. Can you update to a new snapshot and try again?



  • Jimp thanks for the update  ..can you point me where to get the snapshot ..thanks


Locked