[FIXED] Darkstat install issue after each upgrade



  • Hi,
    Using:
    2.0-BETA4 (i386)
    built on Fri Dec 10 18:19:05 EST 2010

    With the last upgrades of PF that I have made, the darkstat package install display this error message:

    Syncing packages : darkstat
    Warning: invalid argument supplied for foreach() in /etc/inc/pkg-utils.inc(370)
    : eval()'d code on line 4
    
    Syncing packages: done
    

    After that Darstat is installed but not functionnal (trying to access darkstat web page result in a loading error). To solve this, I have to go to darkstat setting and hit the save button. After this, darkstat web page is available.

    Thanks



  • Try again.



  • Same issue with:

    2.0-BETA4 (i386)
    built on Sun Dec 12 23:37:33 EST 2010


  • Rebel Alliance Developer Netgate

    @romainp:

    Same issue with:

    2.0-BETA4 (i386)
    built on Sun Dec 12 23:37:33 EST 2010

    That snapshot was built before the message asking to try again, so any change made at that point is not likely to be in that snapshot. Update again and try.



  • Same issue with:

    2.0-BETA4 (i386)
    built on Tue Dec 14 05:32:26 EST 2010


  • Rebel Alliance Developer Netgate

    There were some package commits today that should be in the snapshot that is dated later in the day. Not sure if it would affect that or not, but it's worth updating one more time and seeing. If it still errors off, please post a screenshot of the error complete with the browser URL if you can.



  • Ok perfect, in this case I will uninstall and then reinstall the package and wait until the next upgrade to see if the issue is gone or not.
    Thanks!

    Darkstat version installed : 3.0.712
    Version installed: 3.0.712

    • Use wan as the interface, save and Darkstat works at that time (please note that by default Darkstat will not works until you press at least the save button on the darstat settings page)


  • Ok, this the procedure described above and 2.0-BETA4 (i386) built on Wed Dec 15 07:49:38 EST 2010, the issue disappeared.
    Thanks!


Locked