Captive portal appers broken on latest snapshot



  • I have a number of 2.0 installs running with captive portal. Yesterday I updated to the latest snapshot and the captive portal stopped working. I updated today and still have a problem. I verified with an update to my box at the office. when the captive portal is enabled I do not get the redirect page. I can get the page if I out router ip+:8000 in the browser bar. I can then login and get online.
    I am using alix boards which had snapshot from oct 10 installed. These were working.
    When I upgraded to snapshot from yesterday and also today it broke it. Any ideas?



  • Did you happen to have CP working on snaps between 12-5 and 12-7?

    I am having the same problem and trying to troubleshoot also



  • Dont have anything running those snaps. Sorry.



  • likely the same issue with Squid transparent proxying, NAT reflection, and maybe other things, it's being worked on.



  • cmb,
    I think you are right.
    I attempted CP with Transparent Squid, HAVP after reading a post about another fix that was added to the snaps. (prior builds i think from Nov)

    My Systems are running Squid, Squid Guard, HAVP, Snort, Light Squid.

    Thanks for your help.



  • CP work well last week, after an update from these day, don't work any more !



  • After some more testing today it looks like sometime around the first of Nov. it broke. I tried a snapshot from 10/30 and it worked. When I went to 11/4 it didn't. Hope this helps someone know where to look.


Locked