Broken Console Display in Latest Builds



  • I notice that on build 6 December my console looks normal.

    The first line says Welcome To Pfsense….......

    The last line says: Enter an option...

    On Build December 10 (which does not work for me) and build December 8 (which works for me) the console is "broken".

    The first line says: syncing packages: squid....

    Then a few lines with more messages ending in: FreeBSD/i316 (pfsense.local) (ttyv0)

    Then the: Welcome To Pfsense.........

    The options 0 - 14 are spread out over two columns (instead of one column) and the last line is: Enter an option.....

    This may be related to the Squid Cannot Work Thread which has been confirmed by Jimp as being broken due to a kernel patch that causes Squid to fail in transparent mode.



  • As of my knowing, its a new feature, not a bug…

    Personally i like it much more than before. Great. Not so many space lost... :)


  • Rebel Alliance Developer Netgate

    The new console screen is supposed to look like this:

    
    *** Welcome to pfSense 2.0-BETA4-pfSense (i386) on pfsense ***
    
      WAN (wan)                 -> em0        -> 192.168.197.148 
      LAN (lan)                 -> em1        -> 192.168.1.1 
    
     0) Logout (SSH only)                  8) Shell
     1) Assign Interfaces                  9) pfTop
     2) Set interface(s) IP address       10) Filter Logs
     3) Reset webConfigurator password    11) Restart webConfigurator
     4) Reset to factory defaults         12) pfSense Developer Shell
     5) Reboot system                     13) Upgrade from console
     6) Halt system                       14) Disable Secure Shell (sshd)
     7) Ping host                         
    
    Enter an option: 
    

    Is that not the case for you as well? It takes up less room on the screen so you may just be seeing more of the boot log higher up that you didn't see before. It's not corrupt at all.

    You can always press Scroll Lock and use Page Up/Page Down to look back in the console history.

    If this is not the case, could you take a picture (even a semi-blurry cell phone picture) of the screen when it is "corrupt"?



  • O.K. Am trying to attach pictures. Jimp The first one is with the build you released to fix the squid problem.

    The second with build December 6 where Squid is broken.

    Man, attaching pictures here is a pain.

    It appears you have to upload somewhere then hyperlink here.

    I have temporarily uploaded the images to a little-used account - hope it works:

    @jimp:

    The new console screen is supposed to look like this:

    
    *** Welcome to pfSense 2.0-BETA4-pfSense (i386) on pfsense ***
    
      WAN (wan)                 -> em0        -> 192.168.197.148 
      LAN (lan)                 -> em1        -> 192.168.1.1 
    
     0) Logout (SSH only)                  8) Shell
     1) Assign Interfaces                  9) pfTop
     2) Set interface(s) IP address       10) Filter Logs
     3) Reset webConfigurator password    11) Restart webConfigurator
     4) Reset to factory defaults         12) pfSense Developer Shell
     5) Reboot system                     13) Upgrade from console
     6) Halt system                       14) Disable Secure Shell (sshd)
     7) Ping host                         
    
    Enter an option: 
    

    Is that not the case for you as well? It takes up less room on the screen so you may just be seeing more of the boot log higher up that you didn't see before. It's not corrupt at all.

    You can always press Scroll Lock and use Page Up/Page Down to look back in the console history.

    If this is not the case, could you take a picture (even a semi-blurry cell phone picture) of the screen when it is "corrupt"?


  • Rebel Alliance Developer Netgate

    That's just how it's supposed to look now. Nothing corrupt there at all.



  • Well, it is a New Feature. I personally would not like to see the trailing bootup ending messages hanging up at the top but perhaps there is good reason to have it that way now…..

    @jimp:

    That's just how it's supposed to look now. Nothing corrupt there at all.


  • Rebel Alliance Developer Netgate

    They were always there. They just scrolled off the screen before.



  • That's what I call the "Smooooooth" version of the menu.  Nice and compact.

    It's OK.



  • +1 for the new menu.  Thanks guys!



  • @mromero:

    Man, attaching pictures here is a pain.

    Couldn't be much easier. Hit Additional Options when you're posting, attach the files there.



  • Beg to disagree. Click Insert Image should immediately ask me to upload my image and select source.

    Why ANOTHER click - wearing out my fingers  ::)

    @cmb:

    @mromero:

    Man, attaching pictures here is a pain.

    Couldn't be much easier. Hit Additional Options when you're posting, attach the files there.



  • @mromero:

    Beg to disagree. Click Insert Image should immediately ask me to upload my image and select source.

    Why ANOTHER click - wearing out my fingers  ::)

    The good news is we run an open source forum.  Hack the feature in ! ;)


Locked