RRD Graph, WAN not correct, LAN is correct.



  • HI, I know there is a thread about RRD Graph, but this thread seems to tell that the problems are solved and the problem was that the graph wasn't being generated.

    My problem is more like the totals aren't correct.

    When looking at the WAN the graph are correct, but the total doesn't compute correctly.

    When looking at LAN, the graph are still correct and the total does compute correctly…

    I can tell that the WAN graph are correct, because thay are exact mirror of the LAN graph...



  • I just want to let you know that I updated to latest version yesterday and the rrd graph show the same problem.



  • I think this is bigger problem, not limited only to pfSense and gathering interface statistics.
    I use different software to monitor servers and also have similar problems when using SNMP and RRD.
    Even if there is no communication problems between monitoring server & being monitored server RRD graphs are not always graphed.

    I use RRDTool 1.3.x & NET-SNMP 5.x to gather data. Will check if RRDTool 1.4.x is better.






  • Hi, I've got the same issue here,
    This happen when I use Traffic Shaper.  When I delete all my Traffic Shaper queues/rules" the RRG Graph report data correctly(old data and new). That lets me think that when we use Trahic Shaper, RRD Graph use one of the traphic shaper queue and not actualy "WAN". If I recall correctly this issue were not present on the 1.2.3 version of pfsense.


Locked