Fixing Squid Transparent Proxy on 2.0



  • I had an installation today where a 2.0 beta box with a new (today) install of Squid would NOT work with transparent proxy.

    After digging, I found that the redirect rules were not being created.

    I found that this setting under Advanced :  Firewall/NAT :

    _ Automatically create outbound NAT rules which assist inbound NAT rules that direct traffic back out to the same subnet it originated from.
    Currently only applies to 1:1 NAT rules. Required for full functionality of NAT Reflection for 1:1 NAT.

    needed to be checked.  Once I checked that and saved again (for the umpteenth time) my squid config, the redirect rules were created.

    This is being posted to help others and in case it's a developer issue or bug.

    Firewall had latest 2.0 firmware from today.



  • Thanks for sharing - I was holding off on testing 2.0 as Squid is a critical part of why we use pfSense.  I have noticed there were tickets open on this issue, so perhaps posting to the 2.0 beta forum or actually responding to one of the open tickets would be helpful.

    http://redmine.pfsense.org/issues/1096


  • Rebel Alliance Developer Netgate

    Squid+Transparent proxy should be fixed with current snapshots. It had nothing to do with that setting, but a different bug.

    That may have made it work, but not for the right reasons.


Locked