Load Balancing Screen sees only only 1 WAN



  • Trying to set up the failover configuration as shown on the wiki at
    Mulit-WAN version 1.2x having some problems:
    The symptom is when I go to the Load Balancer to set the failover, I can see only one WAN in the pull-down menu.

    First: the title says  Mulit-WAN version 1.2x  but I am assuming there is not a separate version for pfsense for Multi-Wan.
    I'm using pfSense 1.2.3-RELEASE

    My configuration is
    WAN1 - a DSL with a static IP PPPoE (modem is bridged)
    WANComcast - Cable Modem (bridged) static IP

    I have set it up as shown except

    In the wiki, under
    "USING THE PfSENSE WIZARD"
    Section:
    WAN configuration - the instructions say to set up the
    IP 192.168.0.1 Gateway: 192.168.0.254
    And OPT1 Interface IP 192.168.1.1. Gateway: 192.168.1.254
    This did not work for me and so I set up both interface IP addresses with the static IP addresses assigned and left gateway blank.

    In Ping Diagnostics, both WANS appear to be working.

    The problem arises when, in the load balancing section, I try to “ADD To POOL”
    Only my WAN is showing up, rather than the two WANS I have configured.

    Can anyone help?



  • Here it is explained in detail and with pictures.
    Give it a try.

    http://doc.pfsense.org/index.php/Multi_WAN_/_Load_Balancing



  • Still only shows "WAN" in the load balancer dropdown. It should be showing both of my internaces, WAN and WAN2.

    I believe I have the interfaces set up properly. on the pfsense console screen

    OPT1(Wan2)* -> re0 -> xx.xx.xx.xx                note: Cable Modem
    WAN*            -> dc0 -> yy.yy.yy.yy.(PPPoE)  note: DSL
    LAN*            -> rl0  -> 192.168.2.22

    The * Suggests they're all working

    Under firewall->rules I've set up Wan2 with pass * * * * * *
    (is this right? Dont have the checkbox options for block private and block bogon. Does this indicate a possible problem?

    Also, I did not set up the interfaces for dhcp as I did not want to change the dhcp tables in the cablemodem – as set in brindge mode this is inaccessible.
    In addition, I noticed that in the Wan2 I did not have the option, as I do in WAN1 to  set it up as a PPPoe -- don't need this as it is a cablemodel in bridge mode, but it does stike me as odd. In GENERAL CONFIGURATION of WAN I have the options of PPOE, Static, Dhcp, and PTPP. In the GENERAL CONFIGURATION of Wan2 I only have static and DHCP. My WAN is the DSL and uses PPPoe so I have it set that way with the username and password below.

    Any Guideance?
    I am pretty stuck here.



  • You must have a gateway configured on the interface for it to be a WAN, and to show up there. Set it to whatever IP info your ISP assigned.


Locked