TIMEOUT - WRITE_DMA retrying



  • Hi,

    I use VirtualBox for testing pfSense i386 VM with dual WAN config, installed from CD iso.
    This night I upgraded it
    from: Tue Nov 30 13:09:03 EST 2010
    to:    Sun Dec 19 05:36:18 EST 2010
    I don't know why, but this is resoulting in TIMEOUT WRITE_DMA error. This hasn't happend before. My host hdd is ok, no errors.
    Virtual hdd is attached to SATA controller. This happend when upgrade was completed and pfSense says it's going to reboot.
    Can anyone confirm this happend for real hardware, too?


  • Rebel Alliance Developer Netgate

    How do you have your HDD and CD setup in VirtualBox?

    A long time ago I had some issues when the CD was placed in certain areas (I forget if it was secondary slave, or secondary master, or what) and I saw crashes and errors, but it's been pretty stable for me lately, especially when the host OS is FreeBSD.



  • Screen of VM configuration attached.
    simple: first SATA is HDD, secondary master IDE is CD-ROM.
    No ISO image attached to CD-ROM.
    But it looks like one of last snapshot has buggy SATA driver module???
    Again, I'm telling this never happend before.
    I missed something: i use 2 x wlan cards for dual wan, but there is only one available (I disconnected USB wireless card, so there is only wlan0).

    EDIT: what is default filestystem for pfSense? I see nothing there..







  • Rebel Alliance Developer Netgate

    Default filesystem is ufs2. Linux can't read/write (and definitely can't fsck) that, it's a FreeBSD filesystem.

    The SATA drivers have not changed on snapshots in months, it is not likely that something would have suddenly become "buggy" there.

    Try making the CD-ROM the primary master on standard IDE, leave the HDD on the first SATA port.



  • Unfortunately, this doesn't work.

    But I think this depends on Vbox internal problem, not caused by pfSense.
    Why? Becouse Vbox hangs when I'm trying to do anything (reboot/shutdown VM) just after updating pfSense to new version.
    Now I lost my VM, becouse snapshot didn't worked. Have to do clean install.
    If I discover something missed, this thread will be updated.



  • Rebel Alliance Developer Netgate

    If the Ubuntu version is like FreeBSD, after any update to VirtualBox it also updates the Kernel module, which you have to unload and then reload the updated version, or reboot and load the updated version. Perhaps something similar is happening to you.

    I run a couple pfSense test VMs on my VirtualBox install on FreeBSD and they work fine


Locked