Can't start squid? pfsense 2.0 squid 2 or 3



  • I can't start squid, on status > services, hitting starto n squid, does nothing, it freezes the web page for a second, then nothing.

    I have reinstalled both squid2 and 3, and I think it was working, until I uninstalled squid2, and then installed squid3. I have tried reinstalling both, but the config for squid is the same when I reinstall(As in the webgui remembers all the settings), does anyone know where the squid config file is located so I can delete it?

    I saw in another thread to try squid -Nd1

    but it does nothing in shell.



  • EDIT: Just rebooted pfsense, it had a lot of squid messages on the console, pressed ctrl c to get to the main screen…Then it couldn't recognize the interfaces, and when I tried to set them, it gave me an error, had to reinstall...
    Sorry I didn't write down the error message, oh well. My suggestion is don't to play with Varnish and squid 3  :-*


  • Rebel Alliance Developer Netgate

    Without specific error messages from the console and system logs, there is no way to track down what the problem is or was. If you manage to reproduce it again, post the errors and perhaps we can figure out how to fix them.

    "Don't play with …" is also a bad idea, because if they really are broken, and nobody tries them and reports the errors they get, then they'll never be fixed.

    The best suggestion would be to play with them properly: In a lab, a VM, or a test environment of some kind.



  • I know, I apologize for being a giant douchebag, but I was in a hurry to get back online.


Locked