Spamd issues



  • Hoping somebody can help me.

    I have been using spamd for a while but recently upgraded to v1.2.3 of pfSense which seems to have broke spamd. I reinstalled the package. I uninstalled. Rebooted. Installed. But still the same.

    It seems that in the 'retries' column under 'spamd database' that some of them have 7, 8 or 9 retries and are still greylisted. Some of the whitelist entries have retries at 2, 4, 1 etc too. I thought it was supposed to be whitelisting at 3 retries?  I'm confused about this.

    I also kept getting the message:

    spamd[24062]: /sbin/pfctl returned status 1

    Under System Logs. Not sure what it was/ Did find this thread http://forum.pfsense.org/index.php?topic=18405.0 but didn't get a resolution and didn't understand the last message in the thread.

    Can anybody tell me the current version of spamd (I have 4.3.7), the current maintainer (as it doesn't appear to be listed) and whether it does in fact work on v1.2.43 of pfSense or whether I'm flogging a dead horse.

    Many thanks in advance.


  • Rebel Alliance Developer Netgate

    I'm not sure if the current version of the package as it exists now is fully compatible with 1.2.3.

    A commercial support customer recently sponsored some work on the package (done by Efonne) and last I knew it was at least working on 2.0.



  • @jimp:

    I'm not sure if the current version of the package as it exists now is fully compatible with 1.2.3.

    A commercial support customer recently sponsored some work on the package (done by Efonne) and last I knew it was at least working on 2.0.

    Thanks for that. Will need to wait for v2 then …



  • Hi
    My system is 2.0-BETA4 (i386) built on Tue Dec 21 12:44:54 EST 2010 and use spamd.
    Works fine.


Locked