Squid3 Error when starting



  • 2010/12/21 14:30:12| WARNING: -D command-line option is obsolete.
    2010/12/21 14:30:12| WARNING: Netmasks are deprecated. Please use CIDR masks instead.
    2010/12/21 14:30:12| WARNING: IPv4 netmasks are particularly nasty when used to compare IPv6 to IPv4 ranges.
    2010/12/21 14:30:12| WARNING: For now we will assume you meant to write /24
    2010/12/21 14:30:12| ERROR: '0.0.0.0/0.0.0.0' needs to be replaced by the term 'all'.
    2010/12/21 14:30:12| SECURITY NOTICE: Overriding config setting. Using 'all' instead.
    2010/12/21 14:30:12| WARNING: (B) '::/0' is a subnetwork of (A) '::/0'
    2010/12/21 14:30:12| WARNING: because of this '::/0' is ignored to keep splay tree searching predictable
    2010/12/21 14:30:12| WARNING: You should probably remove '::/0' from the ACL named 'all'
    2010/12/21 14:30:12| WARNING: Netmasks are deprecated. Please use CIDR masks instead.
    2010/12/21 14:30:12| WARNING: IPv4 netmasks are particularly nasty when used to compare IPv6 to IPv4 ranges.
    2010/12/21 14:30:12| WARNING: For now we will assume you meant to write /32
    2010/12/21 14:30:12| aclParseAclList: ACL name 'allow' not found.
    FATAL: Bungled squid.conf line 61: reply_body_max_size 0 allow all
    Squid Cache (Version 3.1.9): Terminated abnormally.
    CPU Usage: 0.018 seconds = 0.018 user + 0.000 sys
    Maximum Resident Size: 6564 KB
    Page faults with physical i/o: 0

    What I've done to solve this issue

    vi squid.conf

    then i have made a comment on the following Lines

    request_body_max_size 0 KB
    reply_body_max_size 0 allow all



  • So is this all we need to do to get Squid 3 running properly on Pfsense 2.0 ?

    Is it possible to edit the file within the WebGui with the Edit File option?

    Can you fine tune Squid 3 within Pfsense, General Settings, Cache Management, Traffic Management etc.?

    Thanks

    @BuLLeT:

    What I've done to solve this issue

    vi squid.conf

    then i have made a comment on the following Lines

    request_body_max_size 0 KB
    reply_body_max_size 0 allow all



  • I don't have much time today to work on that, but i will look forward if the team of pfsense does not correct the error first



  • @BuLLeT:

    I don't have much time today to work on that, but i will look forward if the team of pfsense does not correct the error first

    I am experiencing the same problem with squid3 since the early betas of pfsense 2.0

    The simplest solution I found is to comment out the line
    reply_body_max_size
    in /usr/local/pkg/squid.inc

    it's required to do so after each update of firmware only, not after each restart of service or server


Locked