Wireless Router not getting LAN IP?



  • I just did an update (on pfSense) last night from Oct 3, 2010 to Dec 20, 2010 and now it's (being a few things) not working.

    My Setup:
    [Modem] -> [pfSense] -> [Wireless Router (Cisco M20)]

    I am able to ping google.com (I use google for my ping's) with pfSense, but am unable to ping with my wireless router.
    I started to look into the DHCP, and noticed that pfSense isn't letting the Wireless Router get an IP.




  • you seems to have static on your AP
    change it to DHCP.



  • @singerie:

    you seems to have static on your AP
    change it to DHCP.

    I changed it to Auto DHCP, and it connected but still wouldn't ping out.
    There also wasn't anything in the DHCP logs after I did that.



  • Have you following the recommendations in
    http://doc.pfsense.org/index.php/Use_an_existing_wireless_router_with_pfSense

    If you are using the "WAN" port on the router do you have NAT enabled? If not, do you have a static route defined on pfSense so that it knows where to forward packets destined to the "LAN" (or downstream) side of the wireless router and do your firewall rules allow traffic on the LAN interface from non LAN network IP addresses?



  • What I don't understand, is it was working perfectly (with no modifications) before the update.
    As soon as I updated, the Wireless Router wouldn't get a LAN IP from the pfSense (and yes, I did try to assign it one) or the WAN IP (which I was able to get under pfSense).


Locked