Problems while booting BETA4



  • Hi!

    I have exactly the problem which is described in:

    http://forum.pfsense.org/index.php?topic=25584.0

    Booting 1.2.3 worked fine, but while booting 2.0 BETA4 I'm getting the mounterror.
    I'm not able to configure the ATA-Interface via the BIOS. (there is no possibilty in the BIOS)

    Does anybody have an idea, how I can fix the problem?
    I'm working with an HDD, not an USB/CF device.

    Thanks,
    Leiste



  • Could the problem be something like what is described here:

    http://forums.freebsd.org/showthread.php?t=8729

    ?



  • What variant of pfSense - embedded or full?

    What sort of hard drive - IDE or SATA?

    Is the hard drive recognised by the startup code? The startup should report your hard drive a bit before the mount error, for example:

    ad0: 955MB <transcend 20071207=""> at ata0-master UDMA33</transcend>
    

    Please provide the text of the mounterror message and the few line preceding it. Sometimes this provides useful clues as to what is happening.

    How did you transition from 1.2.3 to 2.0 - fresh install or firmware upgrade?

    Did you attempt to apply the suggested fix from http://forum.pfsense.org/index.php/topic,25584.0.html?

    What sort of platform are you using? (Alix? WRAP? Soekris? Dell R610? ….)



  • Variant: Full.
    IDE Harddrive.

    How did you transition from 1.2.3 to 2.0 - fresh install or firmware upgrade?
    Firmware Upgrade.
    I also tried to install 2.0 via LIVE-CD - but while installing on this way, im getting errors.

    I'm just using a normal IBM Desktop PC at the moment. (1.2.3 is running fine on it)

    I'll check the report of the harddrive now!

    I have already tried the suggested fix from the link.



  • infos from HDD startup:

    ad0: 38162MB <wdc wd400bb-23fja0="" 13.03g13="">at ata0-master UDMA100
    ...
    ...
    ...
    GEOM: ad0: geometry does not match label (1h,63s != 16h,63s).
    GEOM: ad0: media size does not match label.
    ...
    ...
    ...
    vfs.root.mountfrom=ufs:/dev/ad0s1a/ad0s1a
    vfs.root.mountfrom.options=rw
    If you have invalid mount options...</wdc> 
    

    If I try to mount via:

    ufs:/dev/ad0
    

    ..nothing happens…



  • @Leiste:

    If I try to mount via:

    ufs:/dev/ad0
    

    ..nothing happens…

    ufs:/dev/ad0s1a
    

    would probably give better results, though the GEOM messages suggest there is something unusual about your hard drive.

    The mountroot prompt is looking for the specification of a device path to the root file system. /dev/ad0 is the whole hard drive. It is possible (though a bit unusual) for FreeBSD to use the whole hard drive for the file system. A more usual configuration is to have the hard drive divided into a number of (DOS) partitions (FreeBSD slices) with each slice having its own distinct file system. Hence the suggestion that you probably should provide /dev/ad0s1a (FreeBSD partition a on FreeBSD slice 1 on disk ad0) as the path to the root file system.



  • unfortunately the same…nothing happens.

    I have taken some shots from my screan. When I try:
    'error1.jpg' shows you the error, which I see while booting.
    'error2.jpg' shows you the result of entering '?'

    An if I enter:

    ufs:/dev/ad0a
    

    I getting the error you can see in the picture "error3.jpg".

    Same happens if I try it with:

    ufs:/dev/ufsid/....
    

    error1: http://www.comtus-online.de/download/error1.jpg
    error2: http://www.comtus-online.de/download/error2.jpg
    error3: http://www.comtus-online.de/download/error3.jpg
    (Sorry for the bad quality)



  • Hi!
    I just tried to install the BETA4 via the life CD on my PC.
    While choosing the disk, where FreeBSD should be installed, I'm seeing a error message from GEOM in the backgroung:

    GEOM: mediasize does not match label...
    

    But I'm able to continue. After choosing the partition, installation normally start, but I'm getting this error after seconds:

    bsdlabel: unable to get correct path for ad0s2: No such file or directory
    

    See picture error4.jpg for mor details.

    http://www.comtus-online.de/download/error4.JPG

    Thanks for your help!



  • Hey! :)

    I just changed the HDD to try if it is really a problem with the geometry.
    The other HDD is working fine!
    I do not really af an idea what is the problem with the geometry of the other HDD…

    So my problem is solved...but the general problem not!

    Malte


Locked