Pfsense 2.0 latest nano 2g build - upgrade size failure



  • I've been getting a error trying to upgrade the 2g nano 386 build of pfsense, both from the web gui and from the console.

    "php: : New alert found: Upgrade failed due to the upgrade image being larger than the partition that is configured on disk. Halting. Size on disk: 926 < Size of new image: 928"

    I've tried this originally with 12/14 build - each day it keeps failing with the above error, yesterday I downloaded the 1g build and tried to update - same error but different size messages. I put the full 2g 12/23 build back on it and tried to update again - same error.  It is a USB stick  (tried 3 different 2GB usb sticks) not a CF, otherwise what could be causing this error?


  • Rebel Alliance Developer Netgate

    Usually that means the original image was too small, or your CF lost sectors due to wear over time. (Possible but less likely)

    Have you tried flashing the 2G image to a fresh card and then running an upgrade that as a test to see if it works?

    I can't even remember the last time the NanoBSD slice sizes were changed on the builder code.



  • Trying to upgrade with a full image, not an update file, will cause that message too. Make sure you're using an update file.



  • This is on a USB key not a CF.  New 2GB USB, tried it on two others with the same result.  I'm using the update function from the webConfigurator firmware auto-update section.

    by default it points to: http://snapshots.pfsense.org/FreeBSD_RELENG_8_1/i386/pfSense_HEAD/.updaters/

    This is the default location - is this where the update files are?

    edit: found this log from the "view upgrade" button::

    NanoBSD Firmware upgrade in progress…

    Installing /root/latest.tgz.
    SLICE        2
    OLDSLICE      1
    TOFLASH      da0s2
    COMPLETE_PATH da0s2a
    GLABEL_SLICE  pfsense1


  • Rebel Alliance Developer Netgate

    If you start fresh and image it with a 1GB image, and then later update it, does that work?



  • Fresh USB key I loaded 12/29 nano 1G image on it, setup my 2 WAN and 1 LAN interfaces, did the initial setup steps via webgui.

    on reboot, the dashboard prompted me to upgrade to 12/30 build, clicked on the invoke button, it downloaded it and said it installed it.

    refresh the webgui and the system log has the error:

    "php: : New alert found: Upgrade failed due to the upgrade image being larger than the partition that is configured on disk. Halting. Size on disk: 448 < Size of new image: 450"

    It seems for every image I have tried it is 2 'blocks' too small then the image on the USB key.  The USB key was imaged with physdiskwrite-0.5.2 and the initial image was downloaded from: /FreeBSD_RELENG_8_1/i386/pfSense_HEAD/nanobsd


  • Rebel Alliance Developer Netgate

    I have been continually upgrading my ALIX on CF using the 1G image which is why I asked that – I know for certain that it works reliably.

    There may be something about the USB key that is making the issue worse, or how it is written.

    Can you try to write out the image with Image Writer for Windows?



  • Same result with both the .1 and the .2 release.

    poking around the /conf directory – fdisk does not seem happy

    cat /conf/firmware_update_misc_log.txt

    /etc/rc.firmware: /etc/rc.firmware_notify: not found
    fdisk: invalid fdisk partition table found


Locked