Wan pppoe connection



  • any way to make pf 1.2.3 work like attached diagram?


  • Rebel Alliance Developer Netgate

    Have you tried it and had an issue? I thought that should work as-is.



  • i tried it ,pf wan side pppoe client not working when carrying pppoe traffic  from bridged modem to PF 1.2.3 over VLAN enabled switch like attached diagram.
    jimp did you tried this scenario ?it will be very nice if you can try this on your lab environment.

    best regards in advance.


  • Rebel Alliance Developer Netgate

    I don't have a lab setup to try it like that right now. I seem to recall others doing that with a plain switch successfully, but I'm not sure if anyone has done that over a vlan.

    Is there some reason you have to involve the switch? Or is it just more convenient to wire it that way?



  • jimp it's a adsl mileage problem.Because of adsl range problem i have to locate PF near the adsl modem(modem  bridge mode enabled).

    Now i want locate PF in my data center,that was reason i want to carry PPPOE traffic over untagged vlan switch hierarchy  and make authentication on my PF in data center.



  • I'm getting issues trying something similar as your setup, the only difference is more simple.

    vdsl2#1 <> wan1
    vdsl2#2 <> wan2 <> pf 1.2.3 <> opt1 <> switch <> LAN
                                                opt2 <> TL-WR1043ND (on WAN port)

    Still no joy, also using PPPoE Server.

    Will try again tomorrow, I'm almost cracking up my head!



  • Fixed, I just decided to use static IP.  ;D


Locked