2.0 BETA4-20101226 Squid ERROR



  • Hi to all , I'm getting this error after squid package installation via package manager, I'm using

    pfsense-BETA4-20101225-1650.iso.gz and 20101226

    I need to launch /usr/local/etc/rc.d/squid.sh stop to access the pfsense WebGUI.

    The problem is only accesing the WebConfigurator, all other web addresses work fine (I can surf the web), no rules have been setup yet.

    Thanks for any help.

    best regards.

    Ricardo MR

    **ERROR
    The requested URL could not be retrieved

    While trying to process the request:

    GET /services_dyndns.php HTTP/1.1
    Host: 192.168.149.154
    User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; es-ES; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,/;q=0.8
    Accept-Language: es-es,es;q=0.8,en-us;q=0.5,en;q=0.3
    Accept-Encoding: gzip,deflate
    Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
    Keep-Alive: 115
    Connection: keep-alive
    Referer: http://192.168.149.154/interfaces.php?if=wan
    Cookie: PHPSESSID=6a8794a5102e13a27324485538354cf7

    The following error was encountered:

    * Invalid Request

    Some aspect of the HTTP Request is invalid. Possible problems:

    * Missing or unknown request method
        * Missing URL
        * Missing HTTP Identifier (HTTP/1.0)
        * Request is too large
        * Content-Length missing for POST or PUT requests
        * Illegal character in hostname; underscores are not allowed

    Your cache administrator is admin@localhost.
    Generated Sun, 26 Dec 2010 21:10:00 GMT by localhost (squid/2.7.STABLE9)**


  • Rebel Alliance Developer Netgate

    Did you set squid to run on the same port as your WebGUI?



  • @jimp:

    Did you set squid to run on the same port as your WebGUI?

    Yes I put 80 in the Proxy Port field, the I change It to 8080 with same results (error page).

    Then I read the squid howto:

    http://doc.pfsense.org/index.php/Setup_Squid_as_a_Transparent_Proxy

    and change the port to 3128 and no more error page.

    thanks for reply.


  • Rebel Alliance Developer Netgate

    Yeah in general you want to leave squid's port at the default. The transparent option will do any necessary redirection.


Locked