UPS hpT750 and NUT not working



  • Hello!

    Dec 26 23:07:52 kernel: uhid0: <hewlett-packard 0="" 2="" t750="" intl,="" class="" 0,="" rev="" 1.10="" 0.00,="" addr="">on usbus1
    Dec 26 23:07:52 snmpd[62226]: unknown message from devd socket
    Dec 26 23:07:52 kernel: ugen1.2: <hewlett-packard>at usbus1

    Running latest package and BETA4 (latest build).

    SystemLog:
    Dec 26 23:10:39 php: nut: Service failed to start: check configuration
    Dec 26 23:10:39 php: nut: Starting service
    (Tried from shell also, same error running it manually.)

    NUT is configured for LocalUPS and I've tested a couple of USB variants. But no success.
    Any takers? My UPS not compatible? pfSense not in the mode (BETA4 issue?)

    And a Happy X-Mas and Marry New Year, HICK!
    /iorx</hewlett-packard></hewlett-packard>



  • iorx:

    ssh into pfsense.

    open /usr/local/etc/nut/ups.conf

    replace the contents with this:

    user=root
    [HP]
    driver=usbhid-ups
    port=auto
    

    save it, return to shell.

    run this command:  /usr/local/etc/rc.d/nut.sh start



  • Thank you. But doesn't seem to run…

    Result:

    
    [2.0-BETA5][addo@pfnatte.home]/usr/local/etc/nut(51): cat /usr/local/etc/nut/ups.conf
    user=root
    [hp]
    driver=usbhid-ups
    port=auto
    
    [2.0-BETA5][addo@pfnatte.home]/usr/local/etc/nut(50): /usr/local/etc/rc.d/nut.sh start
    starting usbhid-ups
    Network UPS Tools - UPS driver controller 2.2.2
    Network UPS Tools: 0.29 USB communication driver - core 0.33 (2.2.2)
    
    No matching HID UPS found
    Driver failed to start (exit status=1)
    usbhid-ups failed to start
    
    

Locked