SquidGuard…



  • No, this isn't another thread asking if pfSense supports SquidGuard  :P

    I wrote my own package for it yesterday, but have a few issues I'm trying to work around:

    In the GUI I've set up for managing the rules, my resync function is called whenever I click Save, or add a row to a tab using a adddeleteeditpagefields setup. However, when I delete a row the resync function isn't called - I have to go back to a different tab and click save. Obviously I'm doing something silly, any ideas as to what?

    Also, if I try to uninstall the package, it hangs at Loading Configuration… any silly reason why that might be? I'm a bit reluctant to install it on my production firewall to give it a better test until I can resolve this issue ;)

    Thanks,

    Scott



  • Hmmm, just blatted my test firewall and tried to reinstall my package and it just hangs at "Loading Package Instructions…" - any suggestions?

    Also, it downloads and installs an earlier version of squid, which obviously I don't want it to - can this be overriden in the pkg_config.xml, or do I have to host a version of the package with the @pkgdep squid-2.5.14_3 removed, along with hosting a couple of dependancies?

    Thanks,

    Scott



  • Never mind.

    Looks like something has decided to replace the .inc file with an xhtml 403 error document instead. Unfortunately, I made the error of working it directly on the webserver, which means that all my PHP code is now lost :(



  • if You want - i can send to You my squidGuard package
    I'm finally him with my need's
    May be you see any good idea for you project?  :)



  • Cheers, I wouldn't say no ;)

    I've just rewritten all the PHP, and reuploaded - all the files download to the server, all the packages install, but still stuck at Loading Instructions?!



  • Scott, may be i can help you but pls write you detail problem with simple english.

    PS If you create local rpc PFserver for test package - You also need create local ftp server an other workstation . I catch problem if place source package files to pfsense server - in www server .inc files wonted be executed as php. Becose need ftp! (simple small ftp for example)



  • Hi,

    I have created a local HTTP RPC server, and the server is running an FTP server as well - but I'm not sure where you mean this will come in - I've seen nowhere that you would enter FTP information - needing multiprotocol servers for the package seems a bit silly to me as well?

    The problem I am having is that when you browse packages on my test firewall, my package appears. You click install, it downloads all the files and dependancies and installs them. Then it downloads all the additional files defined in the xml configuration file. These appear in their revelant locations on the test firewall, so that step is OK. Then it says "Loading Instructions…" and hangs there. I have no idea what is happening at this point - or what pfSense is trying to do. I'm guessing it's trying to run the custom installation php section - but with no error report of what is happening it's a bit tough for me.

    I'd like to get my head around this, as I might well be interested in writing more packages in the future - a content filter was something I needed, and knowing the SquidGuard is simple I thought it would be a good starting point.

    If it's that the .inc files need executing as php, then I could rename them to .php - but I use other php scripts on this server that include .inc files and all of those execute fine - you never call the .inc directly after all - it's always used by an include or require statement.

    The other problems I have are:

    1. The FreeBSD package forces an older install of squid - I guess I need to edit the .tbz file and remove/update the squid dependancy in the +CONTENTS file.

    2. When using a tab in CoreGUI that is using a adddeleteeditpagefields configuration, adding a row results in my custom sync function being called. When deleting a row, the custom sync function is not called - I have to click onto another tab and click Save.

    Other than that, everything seems to work OK ( obviously once installed manually  ;) )...

    Regards,

    Scott



  • Why don't you post the .inc and .xml files or give us a link to them. Its kinda impossible to troubleshoot without seeing the package files.



  • I have <loadinstructions..>where my source files loading from pfsense local www (http://pfsense_ip/package/..)
    All xml files good load content, but all .inc files get error execute page wisout his contents. I post all to ftp and all works. Check downloading all files <additional_files_needed>from you project.

    for example - my package

    squidguard.inc

    
     <packagegui><title>Proxy server filter SquidGuard: General settings</title>
    	<name>squidguardgeneral</name>
    	<version>1.2.0_1</version>
    	<include_file>squidguard.inc</include_file>
    
    <menu>
    		<name>Proxy server filter</name>
    		<tooltiptext>Modify the proxy server's filter settings</tooltiptext>
    		Services
    		<url>/pkg_edit.php?xml=squidguard.xml&id=0</url>
    	</menu>
    
    	 <additional_files_needed>ftp://10.62.0.30/packages/config/squidguard.inc</additional_files_needed> 
    	 <additional_files_needed>ftp://10.62.0.30/packages/config/squidguard_cls.inc</additional_files_needed> 
    	 <additional_files_needed>ftp://10.62.0.30/packages/config/upload.inc</additional_files_needed> 
    	 <additional_files_needed>ftp://10.62.0.30/packages/config/squidguard_acl.xml</additional_files_needed> 
    	 <additional_files_needed>ftp://10.62.0.30/packages/config/squidguard_default.xml</additional_files_needed> 
    	 <additional_files_needed>ftp://10.62.0.30/packages/config/squidguard_dest.xml</additional_files_needed> 
    	 <additional_files_needed>ftp://10.62.0.30/packages/config/squidguard_rewr.xml</additional_files_needed> 
    	 <additional_files_needed>ftp://10.62.0.30/packages/config/squidguard_src.xml</additional_files_needed> 
    	 <additional_files_needed>ftp://10.62.0.30/packages/config/squidguard_time.xml</additional_files_needed> 
    	 <service><name>squidGuard</name>
    		<description>Proxy server filter Service</description>
    		<executable>squidGuard</executable></service></packagegui> 
    

    10.62.0.30 - ftp server in other workstation

    pkg_config.xml

    
     <pfsensepkgs><packages><package><name>squidGuard</name>
          <descr>High perfomance web proxy filter</descr>
          <website>http://www.squidGuard.com/</website>
          <category>Network</category>
          <version>1.2.0_1</version>
          <maintainer>dv_serg@mail.ru</maintainer>
          <depends_on_package_base_url>http://ftp13.freebsd.org/pub/FreeBSD/ports/i386/packages-6-stable/All</depends_on_package_base_url>
    
          <depends_on_package>squidGuard-1.2.0_1.tbz</depends_on_package>
          <status>ALPHA</status>
          <required_version>1.0</required_version>
          <config_file>ftp://10.62.0.30/packages/config/squidguard.xml</config_file>
          <configurationfile>squidguard.xml</configurationfile></package></packages></pfsensepkgs> 
    ```</additional_files_needed></loadinstructions..>


  • How you call resync?

    
     <custom_php_resync_config_command>squidguard_resync();</custom_php_resync_config_command> 
    


  • I'll try grabbing the additional_needed_files via FTP like you've done, see if it makes any difference :)

    As for the resync - yes, exactly like that - word for word  :)

    I've also tried custom_add_php_command and custom_delete_php_command as demonstrated in the squid package I was looking at before.

    I can't get to any of the files from where I am today as I'm on a customer site, but I'll look into it when I get home and if I can't get around the loading instructions issue I'll post them up for you all to ridicule  :P ;D



  • Does this work anything like the current squid package?



  • @databeestje:

    Does this work anything like the current squid package?

    Need test  ;D



  • I'm willing to test this package if you'll let me know what I need to do



  • I'm intersted in testing this too.



  • Send me mail plz
    I answer after dayving to new year alkohol down  ::)



  • did you get this going?



  • Package created. Look this topic for installation.
    http://forum.pfsense.org/index.php/topic,3111.msg28544.html#msg28544


Log in to reply