Lightsquid Package not working under BETA5 Dec 26 01:43:40 EST 2010 [FIXED]



  • version: 2.0-BETA5 (i386) built on Sun Dec 26 01:43:40 EST 2010

    Install lightsquid package..

    Beginning package installation for Lightsquid…
    Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading Lightsquid and its dependencies...
    Checking for package installation...
    Loading package configuration... done.
    Configuring package components...
    Additional files... done.
    Loading package instructions...
    Menu items... done.
    Integrated Tab items... done.
    Custom commands...
    Executing custom_php_install_command()...done.
    Executing custom_php_resync_config_command()...done.
    Writing configuration... done.
    Starting service.

    Installation completed.   Please check to make sure that the package is configured from the respective menu then start the package.

    after in syslog I can see the message

    php: /pkg_edit.php: The command 'ln -s /usr/local/bin/perl /usr/bin/perl' returned exit code '1', the output was 'ln: /usr/bin/perl: File exists'

    look the attachment

    and if im trying to access lightsquid report from webgui I get:
    "500 - Internal Server Error"

    Thanks,



  • Rebel Alliance Developer Netgate

    What do you get if you run the following:

    pkg_info -Ix perl
    


  • I get 2 version

    pkg_info -Ix perl

    perl-5.10.1_1      Practical Extraction and Report Language
    perl-5.10.1_3      Practical Extraction and Report Language


  • Rebel Alliance Developer Netgate

    Uninstall lightsquid, pkg_delete perl-5*, then reinstall lightsquid. See if it works then.



  • hmmm

    pkg_delete perl-5*
    pkg_delete: package 'perl-5.10.1_1' is required by these other packages
    and may not be deinstalled:
    mrtg-2.16.2_6,1
    pkg_delete: package 'perl-5.10.1_3' is required by these other packages
    and may not be deinstalled:


  • Rebel Alliance Developer Netgate

    then use pkg_delete -f perl-5*



  • working :)


Locked