Pppoe server auth failure



  • Running 2.0-BETA5 (i386) built on Mon Dec 27 09:05:00 EST 2010

    Setting up PPPoE service -
    Created an account under "user manager" named "test"
    created a group called pppoe
    assigned group "User - VPN - PPPOE Dialin " privileges
    assigned test user to group pppoe

    tried to log in, failed.

    found the following in the pppoe Raw server logs

    
    Dec 27 21:25:36 	poes: [poes11] PAP: rec'd REQUEST #1
    Dec 27 21:25:36 	poes: [poes11] AUTH: Auth-Thread started
    Dec 27 21:25:36 	poes: [poes11] AUTH: Trying INTERNAL
    Dec 27 21:25:36 	poes: OpenConfFile: Can't open file '/var/etc/pppoe1-vpn/mpd.secret': No such file or directory
    Dec 27 21:25:36 	poes: AUTH: User "test" not found in secret file
    Dec 27 21:25:36 	poes: [poes11] AUTH: INTERNAL returned failed
    Dec 27 21:25:36 	poes: [poes11] AUTH: ran out of backends
    Dec 27 21:25:36 	poes: [poes11] AUTH: Auth-Thread finished normally
    Dec 27 21:25:36 	poes: [poes11] PAP: PapInputFinish: status failed
    Dec 27 21:25:36 	poes: Reply message: Login incorrect
    
    

    I created the /var/etc/pppoe1-vpn/mpd.secret file and inserted the "test" users credentials, pppoe login succeeded.

    Shouldn't pppoe be authenticating against the user manager accounts rather than the mpd.secret file?


  • Rebel Alliance Developer Netgate

    The integration is not complete for that, and it probably won't be until 2.1.

    On the PPPoE server instance there is a place at the bottom of the screen to add users. Add users there and it should work.



  • Somehow I missed that.  Thanks for pointing that out.


Locked