Intel 10gigabit CX4 Dual Port => no carrier



  • Hi folks,

    I've got "pfSense-2.0-BETA5-20101227-1807.iso.gz" (i386) running on a box with an Intel 10gigabit CX4 Dual Port network card.
    The problem is the interface never goes up. An ifconfig shows "no carrier" for both ix0 and ix1 interface while the switch shows a functional 10gb link.

    So I installed a win7 and the nic works just fine. I also tested with an Ubuntu 10.10 and it works great, you just need to build the driver yourself.

    Then I tried a stock freebsd 8.1 with the driver from the intel website (ixgbe 2.2.3). And same issue, ifconfig always shows the link down.
    Well, I managed to get the link up 2 times but I have no idea how and the link went down as soon as I did any modification to the interface configuration.

    I read somewhere, you needed to assign an IP to the interface in order to bring it up, doesn't work. I also read that CX4 boards weren't well supported by the ixgbe driver but it was 2 years ago. Could it still be the issue ? Do you have any advice ?

    Best Regards,



  • The FreeBSD ixgbe man page (see e.g. http://www.freebsd.org/cgi/man.cgi?query=ixgbe&apropos=0&sektion=0&manpath=FreeBSD+8.1-RELEASE&format=html) provides an email address to which support issues may be raised.



  • I already tried ;)

    Your message did not reach some or all of the intended recipients.

    Subject: Intel 10gigabit CX4 Dual Port Server / Freebsd 8.1 / Interface never goes up
          Sent: 28/12/2010 10:07

    The following recipient(s) cannot be reached:

    freebsdnic@mailbox.intel.com on 28/12/2010 10:08
                The e-mail system was unable to deliver the message, but did not report a specific reason.  Check the address and try again.  If it still fails, contact your system administrator.
                < fmsmga001.fm.intel.com #5.0.0 smtp; 5.1.0 - Unknown address error 550-'5.1.1 freebsdnic@mailbox.intel.com… User unknown' (delivery attempts: 0)>/freebsdnic@mailbox.intel.com



  • Then I suggest you lodge two PRs (Problem Reports) against FreeBSD 8.1:

    • one against the documentation (ixgbe man page) that it references an invalid email address

    • one providing the details of your ixgbe problem

    FreeBSD PRs can be lodged at http://www.freebsd.org/send-pr.html

    Looking at the FreeBSD revision history for one of the ixgbe drivers suggests Intel have released at least two revisions since the driver of FreeBSD 8.1. I don't know what revision is currently used in pfSense 2.0 BETA 4.


  • Rebel Alliance Developer Netgate

    Before filing a PR, you may need to try to install a more recent FreeBSD snapshot that is from 8-STABLE or at least closer to 8.2. There were likely driver updates that happened after 8.1 that are already in the tree, so you could be reporting a problem in FreeBSD that has already been fixed.



  • jimp > Well as I said, I've installed a freebsd 8.1 and there was no native support for my nic out of the box (but maybe I missed some packages, I'm no bsd user at all) and I had to built the driver from the sources provided on the intel website.

    I'll try to get a 8.2 RC1 up and running and see if I can find the ixgbe driver that is supposed to be shipped with FreeBSD. Any hints on that ?

    Best,


  • Rebel Alliance Developer Netgate

    If you can't get it to work on 8.2, you might try going to Intel's site and downloading the FreeBSD driver for the card. You may have to compile it, but it may include instructions on how to do all of that with the driver.



  • jimp > Well that's what I did with FreeBSD 8.1 and it didn't work. I'll try out with the FreeBSD 8.2 RC-1 but I don't think it'll change much because from what I see it looks like a driver issue rather than a kernel issue.
    (Driver loads fine the kernel, no panic, no weird messages in the kernel log)

    Well we'll see in a couple of minutes. BSD 8.2 is nearly installed.

    edit : Test done. Some issue.

    Should I do a PR on the FreeBSD site ?

    Best,


Locked