Upgraded last night from 1.2.3, most everything fine except local APIC error



  • I upgraded my home pfSense from 1.2.3 to the latest 2.0 snapshot at 12:01 am January 1.  Yes, I am a real party animal.

    No real issues, errors in the log showed that a few packages were complaining, I reinstalled them and/or fixed configuration in the webgui and everything is gravy.

    I am getting this but it doesn't appear to be causing any problems:

    Jan 1 18:06:04	kernel: CPU0: local APIC error 0x2
    Jan 1 18:06:03	kernel: CPU0: local APIC error 0x2
    Jan 1 18:06:03	kernel: CPU0: local APIC error 0x2
    Jan 1 18:04:41	kernel: CPU0: local APIC error 0x2
    Jan 1 18:04:40	kernel: CPU0: local APIC error 0x2
    Jan 1 18:04:40	kernel: CPU0: local APIC error 0x2
    Jan 1 18:04:40	kernel: CPU0: local APIC error 0x2
    

    Any thoughts on the above?  I don't believe these were there before.


  • Rebel Alliance Developer Netgate

    Probably a BIOS issue with the newer OS. Is there a BIOS upgrade you can run on your hardware?



  • I had the same thought, sadly no updates since the current version (from 2006).  It's an ITX jetway board running one of the Geode CPU's.  I like that it is fairly low powered.  Maybe it's time to upgrade to an Atom based solution.

    It's squirreled away and I'm too lazy to dig through the crap I've piled in front of it to actually look at the BIOS to see if there is anything to tweak in the BIOS screen.

    The error is constant, but doesn't seem to be causing any ill effects…..

    Didn't see anything in the 'Tunables' page that looked like I could mess with.

    I did do some searching online and the advanced logging at startup did provide a tiny bit more information but it didn't help me:

    [left]dmesg | grep acpi
    acpi0: <award awrdacpi=""> on motherboard
    acpi0: [ITHREAD]
    acpi0: Power Button (fixed)
    acpi0: reservation of 0, a0000 (3) failed
    acpi0: reservation of 100000, 3def0000 (3) failed
    acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1008-0x100b on acpi0
    cpu0: <acpi cpu=""> on acpi0
    acpi_button0: <power button=""> on acpi0
    acpi_button1: <sleep button=""> on acpi0
    pcib0: <acpi host-pci="" bridge=""> port 0xcf8-0xcff,0x480-0x48f,0x1000-0x10df,0x10e0-0x10ff on acpi0
    acpi_tz0: <thermal zone=""> on acpi0
    atrtc0: <at realtime="" clock=""> port 0x70-0x73 irq 8 on acpi0[/left]</at></thermal></acpi></sleep></power></acpi></award>
    

    Note the:
    acpi0: reservation of 0, a0000 (3) failed
    acpi0: reservation of 100000, 3def0000 (3) failed

    Anyways, I will check the BIOS when I get a chance to see if there is anything to tweak.

    Thanks for the reply.


  • Rebel Alliance Developer Netgate

    APIC != ACPI :-)

    Are you using a full install? If so you may want to try the Uniprocessor kernel instead of an SMP kernel.



  • @jimp:

    APIC != ACPI :-)

    Facepalm!

    I blame the trailing end of the flu.

    edit I am an idiot.

    Edit #2:
    I think the APIC error is gone, I went through the BIOS and changed a few things, changing MPS from 1.4 to 1.1 is about the only setting that I changed that I can imagine was related.

    I wouldn't trust anything I say at this point though, I can't even tell APIC <-> ACPI.


  • Rebel Alliance Developer Netgate

    it's an easy mistake to make, not sure why anyone decided having two components in an architecture named so similarly was a good idea.



  • The error still returned…. so.....

    ....Disabled APIC.

    Error gone.    ;)

    You know what's funny - when I was first drilling through the BIOS I thought I saw ACPI in two places and thought, 'wtf - stupid BIOS'.  Of course, one is APIC and one is ACPI.

    Reading is hard.


Locked