Inactive PPTP/VPN sessions through pfSense stops working after a while



  • Inactive PPTP/VPN sessions through pfSense stops working after a while.

    I really don't know when this started to happen, maybe some early December build.

    But if I have an outgoing PPTP/VPN connection established and don't use it for a while I loose the the ability to tx/rx traffic through the tunnel. In my case it has been from a Windows 7 to a several different PPTP-servers. Same behavior to them all.

    I can keep the tunnel active with ICMP-ping and the connection is never lost.

    I usually keep traffic flowing in the tunnel because I'm working through it. But I discovered this when remotely configuring a clients machine, out of the box Windows 7 machine. Doing some pre-install stuff from there server. The machine where left idle after installation script finished and when I came back to the machine it couldn't connect to the server anymore, tunnel up and reports no errors.

    Any takers on this one?

    Info:
    2.0-BETA5 (i386) built on Fri Dec 31 14:08:23 EST 2010



  • No one?

    Is this some session timeout on UDP or TCP that should be adjusted? Bug in BETA4-5?

    Should I post it as a ticket instead?

    Brgs,
    /iorx



  • bump

    Really sorry to have to bump this, but this is becoming a real issue. Anything I can add to the subject which helps getting this solved?

    Anyone else experiencing the same problem?

    Brgs,
    /iorx



  • Yep, same here.  PPTP connections DO work initially, but will silently fail without disconnecting the MS PPTP client, so it looks as though you are still connected to the VPN, until you try and pass traffic over it.

    Always re-establishes though when I manually drop and reconnect though.

    Annoying, but not a show-stopper, for me anyway…

    Ta,

    Jake



  • I've never posted a ticket on a problem, but this one feels like a real candidate for that. I would really like to this one solved. Have the 2.0BETA installed in my home/office environment. But I do allot of work using VPN… :-(

    So, any one with more experience posting a ticket are welcome to do so on this subject. I'll do it, but scared that I can't provide the information required.

    Brgs,
    /iorx



  • same issue here w beta 5 from 9th Jan



  • Grab a snapshot from tomorrow.
    It has a fix for this.



  • I've been experiencing this same problem since October and it now seems it's fixed.  Just download the latest build and you should be fine.  Since the lastest upgrade my PPTP passthru connections have been working fine.



  • I've noticed this on several builds, currently we are on 2.0-BETA5 (i386)
    built on Wed Feb 23 00:45:41 EST 2011, and having the issue with outgoing pptp connections timing out.


  • Rebel Alliance Developer Netgate

    The previous fix was causing a panic and was backed out, so the bug is back for now until a new fix goes in.



  • Has a new fix been put in place yet?


  • Rebel Alliance Developer Netgate

    No, the PPTP proxy was completely removed since it was still causing some other issues.


Locked