Direcionamento de tráfego através de 2 gateways



  • Olá pessoal.

    Possuo dois links, uma conexão Velox e outra Mundivox respectivamente, sendo que o acesso a Internet em geral está direcionado para a saída WAN. Já o gateway da Opt1 está configurado para ficar "dedicado" apenas a alguns serviços, tais como POP3, SMTP, SFTP, etc. O link apontado para a Opt1 está muito subutilizado e estou tentando apontar um servidor de downloads em minha rede para acessar a Internet "apenas" através deste link, a fim de tirar proveito de sua ociosidade e gostaria de saber se isso é possível.
    Tentei fazer isso criando uma regra em Firewall Rules, inserindo o IP do servidor de downloads no campo source, apontando-o para o gateway da Opt1 e deixando "any" nos demais campos, mas não funciomou.

    Resumindo: tenho 2 gateways em minha rede, WAN e OPT1 respectivamente, e quero criar uma regra para que um determinado servidor só acesse a Internet através da interface Opt1.

    Desde já, agradeço qualquer sugestão.

    Obs: gerencio o firewall através de interface web.

    Grato!



  • A regra está correta Juba.

    Source o endereço IP do host, any pra todos (TCP/UDP para protocolo caso queira) e no fim da regra em Gateway, é só selecionar o endereço IP correspondente da sua WAN 2.

    AGORA, se tiver um proxy configurado nesse cara, ele vai usar a internet do servidor proxy QUE pode estar apontando para a WAN 1.

    Para garantir, teste usando o "tracert" ou "traceroute" caso for Linux, assim verá de forma exata por onde está saindo a comunicação para a Internet.



  • Eu tenho um problema semelhante.
    Tenho 2 Gateways, 1 pra net e outro pro sistema que utilizamos no front de loja.

    Os dois gateways estão na mesma rede, um é 192.168.0.253/24 e o outro é 192.168.0.64/24.

    O gateway 192.168.0.64/24 é um mikrotik. Como fazer que oq for solicitado ora 192.168.1.x/24 use o gateway 192.168.0.64 lá em rules?

    Pq configurei uma static route, e não funcionou.



  • Olá Heitor, antes de mais nada obrigado por responder.

    Ótima sugestão realizar o teste com tracert, mas eu já havia feito isso anteriormente e constatei que tal servidor está saindo pela OPT1 como eu desejo. Até aí nada, o estranho é que quando eu vou verificar o gráfico de tráfego da utilização da banda (Traffic Graph) referente a interface OPT1, não se constata praticamente quase nenhum tráfego, isso com um grande download em andamento a uma taxa de velocidade de quase 2Mega !!! E quando olho o Trafic Graph da WAN, está no limite da banda contratada ou até acima. Até onde eu sei, o certo seria o gráfico da OPT1 estar apresentando um volume considerável de tráfego, até porque este é um link da Mundivox com "banda garantida" que asseguraria tranquilamente uma transferência de acordo com a velocidade contratada. Analisando os gráficos em tempo real, o que a gente entende é tudo está saindo pela WAN, exceto por alguns serviços específicos como pop3, smtp, etc, configurados para utilizar como gateway a OPT1 e que com toda certeza estão funcionando de acordo.

    Tive uma idéia! Fora do expediente, vou startar um download neste servidor e desativar o link da WAN1 para ver o que acontece e digo o resultado aqui. Acho que é o melhor teste a se fazer.

    De qualquer forma, sou muito grato pela atenção.



  • @Heitor:

    A regra está correta Juba.

    Source o endereço IP do host, any pra todos (TCP/UDP para protocolo caso queira) e no fim da regra em Gateway, é só selecionar o endereço IP correspondente da sua WAN 2.

    AGORA, se tiver um proxy configurado nesse cara, ele vai usar a internet do servidor proxy QUE pode estar apontando para a WAN 1.

    Para garantir, teste usando o "tracert" ou "traceroute" caso for Linux, assim verá de forma exata por onde está saindo a comunicação para a Internet.

    Heitor, e se ele tiver um proxy configurado no pfsense como ele faz para direcionar o tráfego de saída do proxy para uma opt diferente, pois o proxy do pfsense só sai pela wan.

    Grato.



  • A observação do Heitor é muito relevante nessa situação! No proxy server em general settings, eu já havia adicionado o IP do bendito sevidor de downloads, onde se lê: Bypass proxy for these source IPs. Em virtude disso, aceredito que o IP deste servidor seja "ignorado" por qualquer regra do proxy.


Log in to reply