SSH Authorized keys "lost" on daily firmware Auto Update



  • Hi Forums,

    I'm having an interesting issue with the daily BETA builds.
    Currently on:
    2.0-BETA5 (i386)
    built on Tue Jan 4 01:12:44 EST 2011

    Here is my issue.  After each update: Using the User Manager, I have to manually edit and re-enable the authorized SSH keys for the admin user and others.  The textarea field does have the correct keys listed after checking "Click to paste an authorized key."  So that is being carried over on the updates. After checking that, I click "save", and then ssh key login works just fine.  At least until the next daily firmware update.

    Thanks in advance!

    ![Screen shot 2011-01-05 at 8.20.40 PM.PNG](/public/imported_attachments/1/Screen shot 2011-01-05 at 8.20.40 PM.PNG)
    ![Screen shot 2011-01-05 at 8.20.40 PM.PNG_thumb](/public/imported_attachments/1/Screen shot 2011-01-05 at 8.20.40 PM.PNG_thumb)
    ![Screen shot 2011-01-05 at 8.21.03 PM.PNG](/public/imported_attachments/1/Screen shot 2011-01-05 at 8.21.03 PM.PNG)
    ![Screen shot 2011-01-05 at 8.21.03 PM.PNG_thumb](/public/imported_attachments/1/Screen shot 2011-01-05 at 8.21.03 PM.PNG_thumb)


  • Rebel Alliance Developer Netgate

    We already had a ticket open for that, but it was closed quite a while ago as being fixed.

    http://redmine.pfsense.org/issues/317

    I reopened it.



  • You are using local authentication or any ldap/radius one?



  • Hi All,

    @ermal:

    You are using local authentication or any ldap/radius one?

    I am using the local authentication.

    Also, I am on the nanoBSD image. (if that matters)



  • Hi All,

    I upgraded the firmware last night to:
    2.0-BETA5 (i386)
    built on Thu Jan 27 01:01:15 EST 2011

    And the SSH key seems to be working fine now.

    Thanks.


Locked