Mail Server Behind PFSense



  • Hi,

    I have a mail server running smarter mail, I recently deployed pfsense 123 and I am able to sent email out but I cannot receive email from outside but I can receive email from inside.

    I need to be able to receive email from outside as well as accessing the web interview of smartermail which is on port 9998 from outside as well.

    I think I need to do NAT port forwarding which I did but I am not getting it to work. I used the automatic firewall rule adding so I guess I don't need to play around with the firewall. Of course, I deleted the default rules in the firewall that prevent access from the outside

    Any help will be appreciated…


  • Rebel Alliance Developer Netgate

    For mail to flow, you need port forwards for TCP port 25, and probably 587 as well if you are accepting mail from clients outside your network and not just other mail servers. And if you need the web admin of that then your port 9998 as well.

    Post screencaps of your rules for Port Forwards and on the Firewall Rules (WAN Tab) and also make sure you have gone over all of the points here:
    http://doc.pfsense.org/index.php/Port_Forward_Troubleshooting



  • Thank Jimp,

    I read the document and I am sure everything / all steps are ok but I forget to mention in my previous post that I have captive portal enable and user have to login to access the internet. Will this be why port forwarding is not working?

    As you suggested, I added both port 25 and 587 to the firewall but it is still now working for me. I also still cannot access the mail interface from outside.

    Doing my test, I replace the pfsense with a linksys router and it works fine for me, I can receive, sent and access the mail interface from another ISP but when I put the pfsense in place - hell no, cannot receive email but yes, I can sent out emails.

    Thx


  • Rebel Alliance Developer Netgate

    Captive portal would do it, yes.

    Go to Services > Captive Portal, Allowed IP Addresses tab, and add two entries for the servers, one 'from' and one 'to' for each.



  • Super Jimp!

    You just made my day - it worked! BRAVO…

    Once I added the IP of the local mail server "TO" and "FROM" all my mails start to drop.......

    Thx again


Locked