Missing files



  • Just updated to current build - Jan 7 on i386 - log shows

    an 7 13:57:46 saslpasswd2: unable to dlopen /usr/local/lib/sasl2/libgssapiv2.so.2: Shared object "libgssapi.so.10" not found, required by "libgssapiv2.so.2"
    Jan 7 13:57:46 saslpasswd2: unable to dlopen /usr/local/lib/sasl2/libgssapiv2.so.2: Shared object "libgssapi.so.10" not found, required by "libgssapiv2.so.2"
    Jan 7 13:57:46 sasldblistusers2: unable to dlopen /usr/local/lib/sasl2/libgssapiv2.so.2: Shared object "libgssapi.so.10" not found, required by "libgssapiv2.so.2"
    Jan 7 13:57:46 sasldblistusers2: unable to dlopen /usr/local/lib/sasl2/libgssapiv2.so.2: Shared object "libgssapi.so.10" not found, required by "libgssapiv2.so.2"
    Jan 7 13:57:46 saslpasswd2: unable to dlopen /usr/local/lib/sasl2/libgssapiv2.so.2: Shared object "libgssapi.so.10" not found, required by "libgssapiv2.so.2"
    Jan 7 13:57:46 saslpasswd2: unable to dlopen /usr/local/lib/sasl2/libgssapiv2.so.2: Shared object "libgssapi.so.10" not found, required by "libgssapiv2.so.2"



  • Hi,

    Do you remember which action you did to have this log ? I am running an old snapshot, and I also have missing libraries, but I never had this king of logs.

    Thanks,
    Pierre



  • Is today's snapshot broken? Sometimes afraid to move forward with daily snapshots when I see reports like this one  :-\



  • @mromero:

    Is today's snapshot broken?

    No. The above looks to be related to SMTP authentication for notifications that Pierre was working on, it's non-fatal in all cases and non-applicable for those who don't use SMTP authentication for notifications.



  • Hum, the code I added does not contain any binary files, all auth stuff is done through some php classes, and do not rely on external binary or library.

    The original post deals with a binary "saslpasswd2", which I do not have on my box. So I think it might be a problem with a pfSense package ?



  • @ppomes:

    The original post deals with a binary "saslpasswd2", which I do not have on my box. So I think it might be a problem with a pfSense package ?

    FYI, saslpasswd2 is installed as a dependency when installing the squid package, and is broken (missing libraries)

    
    # ldd /usr/local/sbin/saslpasswd2
    /usr/local/sbin/saslpasswd2:
            libsasl2.so.2 => /usr/local/lib/libsasl2.so.2 (0x28095000)
            libcrypto.so.7 => /usr/local/lib/libcrypto.so.7 (0x280ac000)
            libgssapi.so.10 => not found (0x0)
            libheimntlm.so.10 => not found (0x0)
            libkrb5.so.10 => not found (0x0)
            libhx509.so.10 => not found (0x0)
            libcom_err.so.5 => /usr/lib/libcom_err.so.5 (0x2820f000)
            libasn1.so.10 => not found (0x0)
            libroken.so.10 => not found (0x0)
            libcrypt.so.5 => /lib/libcrypt.so.5 (0x28211000)
            libopie.so.6 => /usr/lib/libopie.so.6 (0x2822a000)
            libc.so.7 => /lib/libc.so.7 (0x28233000)
            libmd.so.5 => /lib/libmd.so.5 (0x2834d000)
    
    

    Pierre



  • 2.0-BETA5 (i386)
    built on Sat Jan 8 15:33:52 EST 201

    squid package reinstalling , failed, missing files. package broken.

    greetings frank


  • Rebel Alliance Developer Netgate

    Those same libraries went missing once before and I swear I fixed that already. It was something to do with the newer OpenSSL some packages seem to want.

    I'll have to take a look at it again.


  • Rebel Alliance Developer Netgate

    I fixed up a couple things on the builder and started a new package run. Hopefully it will be OK this time. Give it a few hours (or just try it tomorrow) and see if it still does this.


Locked