BUG: Unable to select VLAN in PPPs interfaces.



  • Hi,

    VLAN interfaces does not appear in PPPs link interfaces.

    I have two physical interfaces:

    • le0 (used for LAN)
    • le1 (used for two WANs)

    I have configured two VLAN:

    • le1_vlan101
    • le1_vlan102

    I would like to use pppoe0 with le1_vlan101 and pppoe1 with le1_vlan102 but these interfaces don't appear in "Link interface(s)" (in PPPs configuration page)

    I'm using 2.0-BETA5 (i386) built on Thu Jan 6 02:06:43 EST 2011

    Regards,
    Xavier.



  • Please do not post in many places.
    You have the explanation on the ticket.



  • For anyone else encountering this problem: G Brinton in http://redmine.pfsense.org/issues/1178 suggested:

    Here are the steps to follow.

    )create VLANs (example vl1 and vl2) on you leX interfaces.
    )Assign those vlans to OPT1 and OPT2 (or OPTx) and enable them.
    )Go to Interfaces_PPPs and select OPT1 or OPT2 for the Interface that you're using for PPPoE
    )Go to Interfaces_Assign and select the newly create PPPoE(vl1) for your WAN link. If you have Dual WAN, then create OPT3 and assign the PPPoE(vl2) interface to it.
    )Done. WAN should come up then.

    which worked for me (pppoe on VLAN on rl0).


Log in to reply