Dual 3G router



  • Hello everyone, I'm new to the forum and I hope you can help me with my problem.
    I have two 3G usb modem and I want to use them for load-balancing link with other computers on the LAN.

    3G-1 –->    (USB1)---------------
                            |PC with pfSense|(LAN)      ---> Switch ecc...
    3G-2 --->    (USB2)---------------

    I installed pfSense on pcrouter and asks me to identify the WAN port (the second ethernet card) but the WAN port does not exist.
    Can I delete the request of the WAN port with a few commands on startup?! If I have to create a 3G router does not make sense to set the WAN port that does not exist...

    Thank you

    Fabio



  • Are you using a snapshot build of pfSense 2.0? There is support in that version for a number of different types of 3G modems. 2.0 is not yet considered ready for production use and sometimes the snapshot builds have serious bugs but there have been many reports of people using it particular snapshot builds in production environments.

    I have used the 3G modem support in a few different 2.0 snapshot builds with good results.



  • No, i'm using pfSense 1.2.3 livecd but my problem is the WAN port not 3g usb modem.


  • Netgate Administrator

    If you switch to V2.0 you can install with only one NIC. This is so that you can use VLANs but I can't why it wouldn't also apply in your situation.
    I have been using the 18/12/2010 1G image with no problems. (not for 3G though  ::))

    Steve



  • :-[
    does not work…....
    I tried pfSense 2.0, but I have another problem, does not recognize my 3G modem (huawei E173, huawei k3765h, wave mt503hs).  ???
    I tried both virtual (vmware) and real (my computer) but recognition does not occur (pictures attached):

    http://goo.gl/W4GQf

    http://goo.gl/ZcNUm

    What can i do?!??!?!

    Fabio


  • Netgate Administrator

    Hmm,
    I've played around with one of these a while ago on Ubuntu and from what I remember….
    They have two 'modes'. One in which they appear to be a mass storage device and the other they appear to be a modem. The mass storage mode is so that the drivers (for Windows) can be included on the device. One the drivers are installed (in Windows) it then switches to modem mode.
    Not helpful if you're not running Windows!  ::)
    Your card appears to have both onboard storage pretending to be a CD-rom drive and an SD card slot.
    Have a look at this thread:
    http://forum.pfsense.org/index.php?topic=28649.0

    You will likely need usb_modeswitch or something similar.
    Seems odd that this function isn't already here. Does that mean no multimode usb devices are supported?

    Steve

    Edit: No plenty of multimode devices are supported!  ;D
    Checking the source it looks as though the K3765 should work with a recent snapshot. It looks like there are at least two models though with two different meathods of mode switching.



  • Why the E173 is not working? Is in the list of supported by pfSense 2.0…


  • Netgate Administrator

    Hmm odd.
    What does it come up as when you plug it in? Maybe it has a different number for it's device id.
    It's not listed in the source code for u3g, dated 20 Jan 2011.

    Steve





  • @sircotra:

    Take a look here:

    http://doc.pfsense.org/index.php/Known_Working_3G_Modems

    What have you done about stephenw10's suggestion that you might need to "usb_modeswitch" your modem? I would have suggested that if it hadn't already been suggested.

    I purchased an E1762 from a Telco because it was on that list you referenced. Perhaps I was "lucky" but I didn't have to "usb_modeswitch" it. I can't recall the type of system I first plugged it into, I suspect it might have been a windows laptop and I think Windows might have copied some software from it. Maybe that was a "lucky choice", windows might have done the "usb_modeswitch" for me. Or maybe that was done by the telco when they put their branded software on it.


  • Netgate Administrator

    By default the most multimode modems will come up in mass storage mode when first powered on. Hence if you have a dual boot system you can boot into windows where the driver will feed the right incantation to the modem to switch modes. Then if you reboot into some other OS, as long as the modem wasn't powered off, it will still be in modem mode. Some, like the zte modems, can be fixed in modem mode with the right AT command. Others need a special trick but that's taken care of by u3g, for those modems that are supported.

    Steve



  • option 1 ;

    In the past with the old x870 usb modems for instance .a kernel module had to compiled in,ie obtain module
    and try compiling into the dev kernel and install,the module parameters may have to set in /etc/modprobe
    for your specific modem if its currently supported by the current kernel.

    Looking at the pics you have provided and past experience with other 3g modems,the cdrom mode is initialised,as mentioned by someone else previously ,you have to specify this to off when loading the 3g module at boot or when you do insmod ,ie pass something like eject as a module parameter along with the bus id.
    This can also be written in as a boot script.

    -something like this

    #cat /proc/bus/usb/devices

    should produce something like this

    P: Vendor=1410 ProdID=1430 Rev= 0.00
    S: Manufacturer=Novatel Wireless
    S: Product=Novatel Wireless HSDPA Modem
    C:* #Ifs= 2 Cfg#= 1 Atr=e0 MxPwr=100mA
    I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=usbserial_generic

    #cat /etc/modprobe.conf

    options usbserial vendor=0x1410 product=0x1430
    install usb-interface /sbin/modprobe uhci-hcd; /sbin/modprobe ehci-hcd; /bin/true

    -ndiswrapper would the last resort,where windows inf files are used ,you still have
    to specify the device address as above when using.

    I might try our sierra wireless usb 301 and see how that goes as it has the inbuilt cdrom device.

    There some ideas on this bsd post about the mode switch

    http://lists.freebsd.org/pipermail/freebsd-usb/2009-August/007309.html

    option 2  :

    Although not the ideal you can use a dual wan modem with 4 port switch which support 3g usb devices ( eg billion 7404vgpx) in front of the pfsense machine,this does work but you have to specify the modem as the gateway,which is what we have done in testing,havent tried bridging the 3g router unit as yet .


  • Netgate Administrator

    We successfully 'mode switched' a Novatel 3g modem in another thread by simply 'ejecting' the virtual cd-rom.
    Unfortunately the cdcontrol command is not included in pfSense by default to you need to copy it across from a FreeBSD install. This probably won't work for a lot of modems but it's worth a try as it's easy.

    Steve


Log in to reply