Boot Problem



  • Greetings,

    I have a problem with my PFSense installation as it fails to boot leaving me with the prompt "mountroot>"

    I've read these threads:
    http://forum.pfsense.org/index.php?topic=18154.0
    http://doc.pfsense.org/index.php/Boot_Troubleshooting

    This is the dmesg.boot

    
    # less dmesg.boot 
    Copyright (c) 1992-2009 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
            The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 7.2-RELEASE-p5 #0: Sun Dec  6 22:57:48 EST 2009
        sullrich@FreeBSD_7.2_pfSense_1.2.3_snaps.pfsense.org:/usr/obj.pfSense/usr/pfSensesrc/src/sys/pfSense.7
    Timecounter "i8254" frequency 1193182 Hz quality 0
    CPU: Intel(R) Pentium(R) 4 CPU 3.00GHz (3000.01-MHz 686-class CPU)
      Origin = "GenuineIntel"  Id = 0xf43  Stepping = 3
      Features=0xbfebfbff <fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,htt,tm,pbe>Features2=0x649d <sse3,dtes64,mon,ds_cpl,est,cnxt-id,cx16,xtpr>AMD Features=0x20000000 <lm>Logical CPUs per core: 2
    real memory  = 1064960000 (1015 MB)
    avail memory = 1028259840 (980 MB)
    ACPI APIC Table: <a m="" i ="" oemapic="">
    FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
     cpu0 (BSP): APIC ID:  0
     cpu1 (AP/HT): APIC ID:  1
    ioapic0 <version 2.0="">irqs 0-23 on motherboard
    wlan: mac acl policy registered
    kbd1 at kbdmux0
    cryptosoft0: <software crypto="">on motherboard
    padlock0: No ACE support.
    acpi0:</software></version> </a><a m="" i="" oemxsdt="">on motherboard
    acpi0: [ITHREAD]
    acpi0: Power Button (fixed)
    acpi0: reservation of 0, a0000 (3) failed
    acpi0: reservation of 100000, 3f700000 (3) failed
    Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
    acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
    pcib0: <acpi host-pci="" bridge="">port 0xcf8-0xcff on acpi0
    pci0: <acpi pci="" bus="">on pcib0
    vgapci0: <vga-compatible display="">port 0x2800-0x2807 mem 0xcfd00000-0xcfd7ffff,0xd0000000-0xdfffffff,0xcfd80000-0xcfdbffff irq 16 at device 2.0 on pci0
    agp0: <intel 82945g="" (945g="" gmch)="" svga="" controller="">on vgapci0
    agp0: detected 7932k stolen memory
    agp0: aperture size is 256M
    pci0: <multimedia, hda="">at device 27.0 (no driver attached)
    pcib1: <acpi pci-pci="" bridge="">irq 16 at device 28.0 on pci0
    pci7: <acpi pci="" bus="">on pcib1
    pcib2: <acpi pci-pci="" bridge="">irq 17 at device 28.1 on pci0
    pci6: <acpi pci="" bus="">on pcib2
    pcib3: <acpi pci-pci="" bridge="">irq 18 at device 28.2 on pci0
    pci5: <acpi pci="" bus="">on pcib3
    mskc0: <marvell yukon="" 88e8053="" gigabit="" ethernet="">port 0xc800-0xc8ff mem 0xcfffc000-0xcfffffff irq 18 at device 0.0 on pci5
    msk0: <marvell technology="" group="" ltd.="" yukon="" ec="" id="" 0xb6="" rev="" 0x02="">on mskc0
    msk0: Ethernet address: 00:15:f2:4b:ed:61
    miibus0: <mii bus="">on msk0
    ...skipping...
    ata5: <ata 1="" channel="">on atapci2
    ata5: [ITHREAD]
    pci0: <serial bus,="" smbus="">at device 31.3 (no driver attached)
    acpi_button0: <power button="">on acpi0
    speaker0: <pc speaker="">port 0x61 on acpi0
    fdc0: <floppy drive="" controller="" (fde)="">port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on acpi0
    fdc0: [FILTER]
    atkbdc0: <keyboard controller="" (i8042)="">port 0x60,0x64 irq 1 on acpi0
    atkbd0: <at keyboard="">irq 1 on atkbdc0
    kbd0 at atkbd0
    atkbd0: [GIANT-LOCKED]
    atkbd0: [ITHREAD]
    sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
    sio0: type 16550A
    sio0: [FILTER]
    cpu0: <acpi cpu="">on acpi0
    est0: <enhanced speedstep="" frequency="" control="">on cpu0
    est: CPU supports Enhanced Speedstep, but is not recognized.
    est: cpu_vendor GenuineIntel, msr f2d00000f2d
    device_attach: est0 attach returned 6
    p4tcc0: <cpu frequency="" thermal="" control="">on cpu0
    cpu1: <acpi cpu="">on acpi0
    est1: <enhanced speedstep="" frequency="" control="">on cpu1
    est: CPU supports Enhanced Speedstep, but is not recognized.
    est: cpu_vendor GenuineIntel, msr f2d00000f2d
    device_attach: est1 attach returned 6
    p4tcc1: <cpu frequency="" thermal="" control="">on cpu1
    pmtimer0 on isa0
    sc0: <system console="">at flags 0x100 on isa0
    sc0: VGA <16 virtual consoles, flags=0x300>
    sio1: configured irq 3 not in bitmap of probed irqs 0
    sio1: port may not be enabled
    vga0: <generic isa="" vga="">at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
    ugen0: <american 0="" 2="" 650="" power="" conversion="" back-ups="" cs="" fw:817.v3.i="" usb="" fw:v3,="" class="" 0,="" rev="" 1.10="" 0.06,="" addr="">on uhub1
    Timecounters tick every 1.000 msec
    IPsec: Initialized Security Association Processing.
    acd0: DVDROM <hl-dt-stdvd-rom gdr8164b="" 0l06="">at ata2-slave UDMA33
    ad8: 476940MB <wdc wd5000aaks-08v0a0="" 05.01d05="">at ata4-master SATA150
    SMP: AP CPU #1 Launched!
    
    Manual root filesystem specification:
      <fstype>:<device>Mount <device>using filesystem <fstype>eg. ufs:da0s1a
      ?                  List valid disk boot devices
      <empty line="">Abort manual input
    
    mountroot> ufs:ad8s1a
    Trying to mount root from ufs:ad8s1a</empty></fstype></device></device></fstype></wdc></hl-dt-stdvd-rom></american></generic></system></cpu></enhanced></acpi></cpu></enhanced></acpi></at></keyboard></floppy></pc></power></serial></ata></mii></marvell></marvell></acpi></acpi></acpi></acpi></acpi></acpi></multimedia,></intel></vga-compatible></acpi></acpi></a></lm></sse3,dtes64,mon,ds_cpl,est,cnxt-id,cx16,xtpr></fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,htt,tm,pbe> 
    ``` <a m="" i="" oemxsdt="">This is my /etc/fstab
    

    cat /etc/fstab

    Device Mountpoint FStype Options Dump Pass#

    /dev/ad8s1a / ufs rw 1 1
    /dev/ad8s1b none swap sw 0 0

    
    This is my /boot/loader.conf.local
    

    cat /boot/loader.conf.local

    kern.cam.boot_delay="10000"

    
    I tried everything I could find, but with no success. Every time I reboot the system it fails to find the root partition.
    
    It is installed on a SATA hard disk drive, and I tried to install it on a PATA disk drive, but the boot fails even before reaching this point stating that it cannot find the boot drive.
    
    Any suggestion will be appreciated…
    
    Thank you
    
    Stefano Noffke</a>


  • Was the system installed onto the hard drive plugged into the same socket on the same motherboard as you are using now?

    I have no idea if these suggestions will make things any better:

    1. Boot again and at the mountroot prompt type ? and post the response here. If ad8 is in the output then type ufs:ad8s1a and see if you get a different response

    2. Connect the hard drive to another motherboard socket so you get a much lower unit number (e.g. ad0 or ad1 or ad2), then reboot.

    3. In the BIOS, check if any disk controllers are in AHCI, RAID or some kind of 'enhanced' mode. Change them to 'standard' or 'legacy' mode. BIOS disk controller numbers might not be the same as operating system disk controller numbers.

    4. Try a snapshot build of pfSense 2.0 - its newer device drivers might give better results.



  • Thank you for your reply.

    PFSense has been installed directly on that server.

    If I type "ad8s1a" the system boots normally.

    The BIOS setting for the SATA drives is "Enhanced".

    I will try to set it to "legacy" and reinstall the system.


  • Rebel Alliance Developer Netgate

    You might also trying doing a custom install and make an ~8GB / slice, the same size swap you have now, and make the rest /usr

    There are a couple BIOS implementations out there that flake out with a root slice that large. 500GB is a bit large to put in a firewall. :-)



  • maybe this can help you:

    http://forum.pfsense.org/index.php/topic,32199.0.html

    greets,
    phpzilla



  • Thank you for the replies.

    I was finally able to install it. It now boots normally.

    I set the controller to "Compatible Mode" and created a 4 Gb partition for root. I also used a PATA HDD instead of a SATA HDD.

    Thank you

    Stefano


Locked