Ntop Installion Failed. perl-5.10.1_1.tbz not found. in 2.0 BETA 5(i386).



  • I can't install the ntop.

    http://files.pfsense.org/packages/8/All/perl-5.10.1_1.tbz could not be download.



  • Can anybody reply?



  • It installs fine on the AMD64 build but I'd avoid it like the plague as it installs a load of X11 stuff that should not be there.

    libSM-1.1.1_3,1    Session Management library for X11
    libX11-1.3.3,1      X11 library
    libX11-1.3.3_1,1    X11 library
    libXau-1.0.5        Authentication Protocol library for X11
    libXaw-1.0.7,1      X Athena Widgets library
    libXdmcp-1.0.3      X Display Manager Control Protocol library
    libXext-1.1.1,1    X11 Extension library
    libXmu-1.0.5,1      X Miscellaneous Utilities libraries
    libXp-1.0.0,1      X print library
    libXpm-3.5.7        X Pixmap library
    libXrender-0.9.5    X Render extension library
    libXt-1.0.7        X Toolkit library
    libxcb-1.6          The X protocol C-language Binding (XCB) library
    libxcb-1.7          The X protocol C-language Binding (XCB) library



  • i cant do it in AMD64 build next error send

    Checking for package installation…
    Downloading http://files.pfsense.org/packages/8/All/ntop-3.3.10.tbz ...  could not download from there or http://ftp2.FreeBSD.org/pub/FreeBSD/ports/amd64/packages-8.1-release/All/ntop-3.3.10.tbz.
    of ntop-3.3.10 failed!



  • I have already installed it successfully, but error found when starting it.

    /libexec/ld-elf.so.1: Shared object "libpcap.so.1" not found, required by "ntop"

    ======================
    I have already started it!

    I downloaded libpcap.tbz and installed libpcap manually, made a soft link to libpng.so.6.:)



  • anybody success with ntop? please share experience…



  • 1. Download the libpcap-x.x.x.tbz from http://files.pfsense.org/packages/8/All/ and copy it into pfSense.
    2. run "pkg_add libpcap-x.x.x.tbz" in the command line to install it manually.
    3.
    cd /usr/local/lib
    ln -s libpng.so.6 libpng.so.5
    4. run "ntop" to check whether ntop can be successfully started.



  • Thanks for your help,

    With some pkg_add command for GeoIP and also change symbol link from libz.so.5 to libz.so.4 ntop starting run but when access ntop from web base on command line screen i receive message like
    Libpng warning: Application was compiled with png.h from libpng-1.2.28
    Libpng warning: Application is running with png.c from libpng-1.4.3
    Libpng warning: Incompatible libpng version in applicationn and library

    So how do i make is run with complete compatible?



  • @trunglam:

    Thanks for your help,

    With some pkg_add command for GeoIP and also change symbol link from libz.so.5 to libz.so.4 ntop starting run but when access ntop from web base on command line screen i receive message like
    Libpng warning: Application was compiled with png.h from libpng-1.2.28
    Libpng warning: Application is running with png.c from libpng-1.4.3
    Libpng warning: Incompatible libpng version in applicationn and library

    So how do i make is run with complete compatible?

    :-X
    Sorry, I don't know…



  • anybody try to install ntop 4 manual?



  • you can find a solution here without symbolic links http://forum.pfsense.org/index.php/topic,33901.0.html

    Change freebsd ftp server to the one fits your achitecture.

    Hope this helps.


Locked