Can you change the webconfigurator bootstrap interface to something else?



  • Sorry if this has been reposted, but I cannot seem to find it–probably due to the generality of the search terms I used.  Does anyone know if the webconfigurator app can be bootstrapped or bind to another interface besides the LAN interface?  I want to connect to the webconfigurator over the wireless interface; however, I still want the LAN/ethernet interface configured and up just in case.

    Any ideas?

    edit: never mind, figured out a work around.



  • Doesn't the web configurator bind to all interfaces?



  • It doesn't seem like it.  I have restarted the PHP daemon process several times, and it listens only on one interface.  I found a way to fix my problem, but it was a pain in the butt given that my WIFI interface configuration would cause the kernel to panic and crash.  I would then be subsequently forced to deal with a kernel trap error.  When I figured that out, I was able to switch the LAN interface from the ethernet port to the wireless port.  But then, the new ip address it picked up would disable the webconfigurator's virtual host.  Basically, I locked myself out of webconfigurator.  I tried restarting the PHP daemon, but it would just attach itself to the old IP.  I don't quite understand PHP.  Anyways, what I had to do was reboot the system, and then reconfigure the LAN interface by reassigning IPs and dynamic addresses.  The trick was to restart with the interface settings persisted.  Otherwise, the interface would go out of Access Point (host) mode to client mode.  So, pain in the butt, but I got it to all work.

    Also, I tried to search the PHP forums, to no avail, to figure out how to configure it via its config files to bind to a specific interface.  No luck.


  • Netgate Administrator

    You can access the webgui on any interface as long as you have a firewall rule in place to allow it.
    Only LAN has this (the antilockout rule) by default.

    Steve



  • Ahhh… ok, much thanks!  Sorry for the belated response!


Log in to reply