WebGUI Lockout



  • I have a box running the NanoBSD version of 2.0 on a Soekris 4801.  The console is locked and I have forgotten the password.  I have tried following the instructions on page 76 of the pfSense book, but do not see an option for single user mode.

    What are the proper commands for a password reset in a Nano environment.


  • Rebel Alliance Developer Netgate

    Press enter at the 1/2 prompt, then press space. At the boot prompt, just press enter again. When it continues to boot, you'll get the menu.



  • Thanks Jim

    I tried it, but still haven't quite got it.  I'm sure it is me.  I think I am at 1/2 boot. That is where you have a limited set of commands?  Past that it just continues to boot normally.

    I will play with it some more on my box at home to see if I can get the correct combination.


  • Rebel Alliance Developer Netgate

    Press enter at the 1/2 boot, then just after that, press the space bar. It'll drop to a boot prompt but that isn't where you type the commands, it's just a boot device selection… Just press enter and then the menu pops up. Otherwise you have to time it right and hit space during the spinner after that stage, which is harder to hit over serial. :-)



  • Jim,

    I have tried this a hundred times and cannot get the menu.  Below is the only place I get to.  I have tried the enter, space combination at every stage of boot with no luck. I have followed the instructions exactly it just boots and I never see the menu.

    What am I doing wrong?

    1  pfSense
    2  pfSense

    F6 PXE
    Boot:  1 #
    /boot.config: -h

    FreeBSD/i386 boot
    Default: 0:ad(0,a)/boot/loader
    boot: Consoles: serial port
    BIOS drive C: is disk0
    BIOS 639kB/523264kB available memory

    FreeBSD/i386 bootstrap loader, Revision 1.1
    (sullrich@FreeBSD_8.0_pfSense_2.0-snaps.pfsense.org, Sat Nov 27 03:43:16 EST 201

    Loading /boot/defaults/loader.conf
    /boot/kernel/kernel text=0x886468 data=0x3c9674+0x9b6a0 -
    |
    Hit [Enter] to boot immediately, or any other key for command prompt.

    Type '?' for a list of commands, 'help' for more detailed help.
    OK


  • Rebel Alliance Developer Netgate

    Well that isn't where I got when I tried it last time but that OK prompt is usable. Just type "boot -s" there.

    I can't get the menu today when I try, not sure what the difference is, but as long as you can get to that prompt it should still be possible.



  • That has me closer, but it is still giving me issues.  Don't want to post items directly from the book so I will be a little vague.

    At the # any key I press yields 'stray irq7'
    If I keep pressing enter or any key several times it will finally stop the 'stray irq7' and I get
    '# /stray irq7
    /too many stray irq 7's: not logging anymore

    //: Permission denied'

    After issuing the first command it seems to take it (no errors or feedback) then the second 'reset command'
    I get

    [Sat Nov 27 10:54:33 2010] [apc-error] apc_fcntl_create: open(/tmp/.apc.PPUtTl,
    O_RDWR|O_CREAT, 0666) failed: Read-only file system


  • Rebel Alliance Developer Netgate

    What does "mount" show? It should be rewrite for every filesystem. /var and /tmp are usually on a memory disk on NanoBSD so there may be some oddities there.

    You can try to remount / as rewrite manually:

    /sbin/mount -u -w /


  • Rebel Alliance Developer Netgate

    Also, the same instructions for resetting the password are on the doc wiki, it's not a secret. :-)



  • Got it, but not exactly as I planned.  Somehow I blew away the entire config doing it.  just got it rebuilt.


Locked