[Solved] Boot Disk Error



  • I have been trying for the past couple of days to install pfsense on an old computer. The live cd boots fine and everything works except for when I try to install it. The installer runs fine with out any errors but then when I reboot the computer I get a disk boot error. I'm not sure what the problem is here. The bios is detecting the drives fine and they are able to boot with linux and with windows (i tried two separate drives witht he same result). I even tried changing the master/slave config and im still getting the same error. I have looked this up on google and here and most of the solutions point to the bios which i do not see any problem with. Does anyone have any pointers?

    thanks,
    Drewgle



  • what is the exact error? or does it just say 'disk boot error'? if so it could be a bios problem.



  • That what i was thinking but i cant seem to figure out what the problem is with the bios. It is picking the drive up just fine. and with another OS it works. I just seems to have problems with pfsense (or bsd).

    The exact message is

    "Disk Boot Failure. Insert System Disk and press enter"



  • Sounds like the bios is not compatible with the default bootloader in pfsense, so you may have to change it. does it boot off the live cd?



  • Yep without a problem. Any good bootloader replacements?



  • during the install of pf there is a choice to install 2 types of boot loaders, would have to do an install to see what they are. but i think its grub and something else.



  • hello  ;D

    i hope i can help you with my small english  ;) i am a pfsense user from germany and i know your problem exactly.
    the reason for this boot problem happen in BIOS configuration:

    1. open "STANDARD CMOS SETUP"
    2. go to "IDE PRIMARY MASTER" or the same in SATA version (SATA PRIMARY MASTER ?) and open it with ENTER
    3. switch Access Mode from "AUTO" to "LBA"
    4. go back until closing BIOS and answer with "Y" to safe your changes
    5. let machine restart and try automatically to start pfsense

    my background of this problem:

    i install pfsense normally and all is going good
    then pfsense will restart and i got this failure like you got. like you i try several ways to clean the failure with no good result.
    so i try in bios this and that  ::)

    at last i try to change access mode (phoenix bios) from auto to lba and restart the machine AND IT WORKS !
    so i hope it will helps you also to try my way !

    greets,
    phpzilla



  • @phpzilla:

    hello  ;D

    i hope i can help you with my small english  ;) i am a pfsense user from germany and i know your problem exactly.
    the reason for this boot problem happen in BIOS configuration:

    1. open "STANDARD CMOS SETUP"
    2. go to "IDE PRIMARY MASTER" or the same in SATA version (SATA PRIMARY MASTER ?) and open it with ENTER
    3. switch Access Mode from "AUTO" to "LBA"
    4. go back until closing BIOS and answer with "Y" to safe your changes
    5. let machine restart and try automatically to start pfsense

    my background of this problem:

    i install pfsense normally and all is going good
    then pfsense will restart and i got this failure like you got. like you i try several ways to clean the failure with no good result.
    so i try in bios this and that  ::)

    at last i try to change access mode (phoenix bios) from auto to lba and restart the machine AND IT WORKS !
    so i hope it will helps you also to try my way !

    greets,
    phpzilla

    Yes this was it! You are awesome. Thank you, and thanks everybody for all of the replies. After making that change everything works great now.


Locked