Problems with traffic shaper



  • With the last update i get

    [filter_load]There were error(s) loading the rules: pfctl: should have one default queue on pppoe0pfctl: errors in altq config The line in question reads [ should have one default queue on pppoe0pfctl]:

    No internet connection to outside.
    Disabling the shaper resolves the problem. What can i do here?

    The shaper worked perfect over the last week, so i'm a bit confused.



  • Possibly you have removed the default queue option from the queues nothing else.



  • Uh, no.

    I had default queue at qOthersDefault and qP2P. That was the error. So is this a feature or possibly a bug? If more than 1 default queue is ticked, there should be a warning. Or maybe better, if a queue is made default queue, all other default queue entries should be resetted to be non default.

    thanks much for that hint, ermal!



  • Well it shouldn't be possible to select default multiple times afaik.
    Can you please open a bug in redmine.pfsense.org for this and assign to me.



  • Done. Its the following bug report:

    http://redmine.pfsense.org/issues/1193


Locked