• Hi List. Here is my problem.
    I have two internet link connected to WAN and PAGI. I also have two public IP from one of my provider.
    I set up primary ip address  X.X.X.106 and Alias X.X.X.107 for PAGI (rl0)

    rl0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=8 <vlan_mtu>ether 00:e0:4c:02:74:ea
    inet X.X.X.106 netmask 0xff000000 broadcast X.X.X.X
    inet6 fe80::2e0:4cff:fe02:74ea%rl0 prefixlen 64 scopeid 0x3
    inet X.X.X.107 netmask 0xfffffff8 broadcast X.X.X.X
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active

    I set up static routes to my external web server to allow connection only from ip X.X.X.106

    Netwrok    Interface    Gateway
    LAN X.X.X.213/32 X.X.X.105

    My external web server shows that 50% of my connection goes from ip .106 and 50% from .107.
    That was confusing so I added Manual Outbound NAT

    Interface Source Source Port Destination Destination Port NAT Address NAT Port Static Port Description
    PAGI  any * * * X.X.X.106 * NO

    That's works perfect. However I have problem with ftp connection. I can connect to X.X.X.213 but can't list folder.
    Proftpd log shows:
    : Refused PORT X.X.X.107,201,146 (address mismatch)


    Passive data transfer failed, possibly due to network issues
    Check your PassivePorts and MasqueradeAddress settings,
    and any router, NAT, and firewall rules in the network path.
    FTP no transfer timeout, disconnected
    : FTP session closed.</full-duplex></vlan_mtu></up,broadcast,running,simplex,multicast>