Siproxd the config UI isn't working (unable to save)



  • I have pfSense 1.2.3-RELEASE built on Sun Dec 6 23:21:36 EST 2009 using the multicore kernel installed in a vmware (ESXi 4.1) virtual machine.

    I tried to install sipproxd using the automated package installation.  No error during the install process.  But after that, when I'm going to the siproxd config, I'm not able to save the config.  By exemple, both in and out interface are set to "LAN" and if I change the out to WAN, there's a long delay while saving and nothing is saved.

    Anybody experiencing the same problem ?

    Carl.



  • Yes I had the same issue, here's how I worked around it:

    ssh to the pfsense box, edit siproxd.conf file in /usr/local/etc and manually put in the config, then copy that corrected config off the box.

    You will lose that config with each reboot but you can recopy over the corrected config file after each reboot and restart siproxd.


  • Rebel Alliance Developer Netgate

    You probably have a stray "<config>" tag inside of your config.xml in the siproxd settings.

    Download a backup of your config, look for the siproxd settings section. If you see a "<config>" tag, remove it, and then restore that configuration file.</config></config>



  • Oooohh wow, that solved my problem!  Thank you very much!

    Carl.



  • I'm having the exact same problem.  I'll try the backup/edit/restore to fix, but I'm wondering if there is a fix in the package or source that I should log somewhere?


Locked