Squid bloqueando páginas da web governamentais



  • Olá galera. estou usando o pfsense 1.2.3 com proxy squid e squid guard, apenas um site governamental está sendo bloqueado, como posso fazer para liberar, não vi mais opções de filtro. tem uma imagem em anexo mostrando o bloqueio
    sou iniciante, estou gostando muito do pfsense.
    ![erro cagece.JPG](/public/imported_attachments/1/erro cagece.JPG)
    ![erro cagece.JPG_thumb](/public/imported_attachments/1/erro cagece.JPG_thumb)



  • Amigo, seria bom que voce coloca-se aqui as confs do squid e do Dans pois so assim poderemos analisar seu caso.

    Abs



  • segue abaixo minha conf
    obrigado

    Do not edit manually !

    http_port 192.168.1.1:3128
    icp_port 0

    pid_filename /var/run/squid.pid
    cache_effective_user proxy
    cache_effective_group proxy
    error_directory /usr/local/etc/squid/errors/Portuguese
    icon_directory /usr/local/etc/squid/icons
    visible_hostname nervnet.lan
    cache_mgr tiagopeantos@gmail.com
    access_log /var/squid/log/access.log
    cache_log /var/squid/log/cache.log
    cache_store_log none
    shutdown_lifetime 3 seconds

    Allow local network(s) on interface(s)

    acl localnet src  192.168.1.0/255.255.255.0
    uri_whitespace strip

    cache_mem 128 MB
    maximum_object_size_in_memory 32 KB
    memory_replacement_policy heap GDSF
    cache_replacement_policy heap LFUDA
    cache_dir ufs /var/squid/cache 256 16 256
    minimum_object_size 0 KB
    maximum_object_size 64 KB
    offline_mode off
    cache_swap_low 90
    cache_swap_high 95

    No redirector configured

    Setup some default acls

    acl all src 0.0.0.0/0.0.0.0
    acl localhost src 127.0.0.1/255.255.255.255
    acl safeports port 21 70 80 210 280 443 488 563 591 631 777 901  3128 1025-65535
    acl sslports port 443 563 
    acl manager proto cache_object
    acl purge method PURGE
    acl connect method CONNECT
    acl dynamic urlpath_regex cgi-bin ?
    cache deny dynamic
    http_access allow manager localhost

    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !safeports
    http_access deny CONNECT !sslports

    Always allow localhost connections

    http_access allow localhost

    quick_abort_min 0 KB
    quick_abort_max 0 KB
    request_body_max_size 0 KB
    reply_body_max_size 0 deny all
    delay_pools 1
    delay_class 1 2
    delay_parameters 1 307200/307200 -1/-1
    delay_initial_bucket_level 100

    Throttle extensions matched in the url

    acl throttle_exts urlpath_regex -i "/var/squid/acl/throttle_exts.acl"
    delay_access 1 allow throttle_exts
    delay_access 1 deny all

    Setup allowed acls

    Allow local network(s) on interface(s)

    http_access allow localnet

    Custom options

    redirect_program /usr/local/bin/squidGuard -c /usr/local/etc/squidGuard/squidGuard.conf
    redirector_bypass on
    redirect_children 3

    Default block all to be sure

    http_access deny all



  • Uma saida e colocar o IP que o site responde no BYPASS destination



  • :) fazendo o bypass não deu certo, por que não uso o proxy tranparent, mas consegui liberar o acesso em acces control acl safeports e adicionei  a porta 82 deu certo.


Log in to reply