Random freezes



  • I noticed freezes coming with an update I did around a week ago.
    Firstly I thought this was due to my very old box.

    I took the hard drive and NICs and put them into a newer PC (Intel P4D cpu, 2GB memory).
    After some if re-assignment everything worked like a charm as expected.

    But the freezes are still here, they are very random (from minutes of uptime to some hours).
    Nevertheless not totally random I think, as pfSense never freezes during night (very few use).

    I currently use this snapshot :

    2.0-BETA5 (i386)
    built on Wed Jan 19 02:10:47 EST 2011

    I use pfSense in a pretty basic way : outboud Multi Wan, DHCP server, no VLAN, no traffic shaper, no VPN.
    I have nmap and bandwidthd installed.

    One strange thing I noticed is that upload FTP transfers always abort, I do not mean connection during ftp passive listing or so. listing is fine but when upload transfers start they always abort (hundreds of MBs at 1MB/s)

    I don't know how to help more, I have no relevant log in the web interface (or don't know where to find them) and I changed nothing in the configuration since ages ago.
    Ask me informations if needed (and probably how to find it).



  • I've also encountered these random freezes.  I just posted a new topic about also before this topic showed up.  I was running a build from 1/7 which did not have the issue and then upgraded to 1/19 and it started happening.



  • hi,
    woke up this morning and router was frozen.
    first time ever ive seen pfsense freeze.
    good to know im not the only one this has happened to



  • I had the same thing happen on the amd64 1/19 build.  Upgraded to the 1/20 build this morning and have had over 8 hours of uptime so far.



  • known issue with a change in the past couple days, being worked on



  • thanks cmb



  • 2.0-BETA5 (amd64)
    built on Wed Jan 12 18:01:47 EST 2011

    Would "last couple days" go back to Jan 12? I had 8 days uptime until it froze about an hour ago. Fortunately I had a vga monitor connected. Unfortunately I didn't think to take a picture of it, and writing it all down at this hour was out of the question.

    Fragments, as I recall:

    "Page fault 12 while in kernel mode. Not using IRQ"
    "em1 IRQ 259"
    "not dumping. no device defined"
    "rebooting in 15 seconds. press any key to abort"
    "halting CPUs"

    Then it froze, no actual reboot.

    Sorry if that's too jumbled or incomplete to be useful. If there's a next time I'll grab the camera.

    Is there a last known safe snap?



  • Thx cmb for the feedback, can you link the issue ticket please ?

    @clarknova : according to your kernel message (em1) I think your issue is linked to this topic : http://forum.pfsense.org/index.php/topic,31721.0.html

    The freeze I'm talking about in this thread gives no message back.


  • Rebel Alliance Developer Netgate

    The crash/panic and the freeze are likely separate.

    The freeze is from the FTP and PPTP proxy code, the crash/panic seems to be related to certain em older network card chipsets.



  • Thx Jimp !

    Is there a way to deactive the ftpproxy during the time a fix is released ?


  • Rebel Alliance Developer Netgate

    Check the thread that's already going for this topic, I gave instructions there:
    http://forum.pfsense.org/index.php/topic,32458.msg167553.html#msg167553



  • Ok, thank you !

    And sorry for the duplicated thread I'll not post in this thread anymore.


Locked