NAT + Portforwarding Useless



  • In pfsense (1.2.3), I have never been able to successfully forward ports using anything except UPnP. I have followed multiple guides and videos and have read much of the useful information on this forum. I recently had a pfsense box die, so I replaced it with a spare and started over from scratch on my firewall and NAT rules (I probably had close to 30). Here is just the beginning to what I have done, and as I expected, nothing is working.

    Firewall Rules
    http://i427.photobucket.com/albums/pp360/xtropx/FirewallRules.jpg

    Port Forward
    http://i427.photobucket.com/albums/pp360/xtropx/NAT_Port_Forward.jpg

    Manual Outbound
    http://i427.photobucket.com/albums/pp360/xtropx/NAT_Manual_Outbound.jpg

    I would be grateful if someone could offer their technical expertise. I am new to pfsense and open-source firewalls and I would really like to learn how to utilize them to their fullest extent. Thanks in advance.



  • Well, I and many others haven't had such problems so there's something very strange going on with your configuration.

    Are you creating the NAT and firewall rules with the wizard?

    Does it work with other devices? What's the WAN IP of the pfSense host (at least the first 2 sets of numbers)? Are you using manual outbound NAT for any particular reason?



  • Delete the outbound NAT entries. Should just leave that on automatic generally. Also read
    http://doc.pfsense.org/index.php/How_can_I_forward_ports_with_pfSense%3F
    http://doc.pfsense.org/index.php/Port_Forward_Troubleshooting



  • @Havok: Yes, it should work. I must be doing something wrong. 24.179 is the first two sets of my IP address. I have never successfully made this work with anything, except i2p, I think. I tried it with xbox 360 as well; same story, only UPnP works. I am not creating the NAT and firewall rules with a wizard, I guess I didn't even know there was one. I am using manual outbound NAT simply because that is the way most of the tutorials and instructions I have come across have suggested. To be honest, I don't really know the difference between the two.

    @CMB: Thanks, I tried switching back to Automatic Outbound, I did NOT delete the entries, just made the change and reset my states.
    I did take a look at both links you posted previous to this post.

    Edit: So here is what is happening. I removed manual outbound entries and changed that, and I also changed the Interface Address on the port forward tab from "ANY" to "INTERFACE ADDRESS." Reset states and everything worked fine! Fired up my game and showed NAT TYPE: OPEN.

    Did some web browsing, nothing major, went to fire up the game again…NAT TYPE STRICT.



  • Yup, still patchy. One day it says NAT open, one day NAT strict. No consistency.  >:( I am still considering port forwarding on pfsense BROKEN because of this, unless someone can offer some insight as to what may be wrong. Maybe time to start searching for a different open-source firewall distro?



  • Please read the threads on XBox360 and UPnP in the gaming forum regarding that OPEN/STRICT issue. Port forwarding, non UPnP, works perfectly with pfSense.


Locked