Disappearing entries and other things



  • I encountered this some days before, but now happens again:

    1. I add a new alias, save that alias, commit changes and add a new rule using that alias. Commit change and the alias AND rule are gone. Not anymore visible. Could it be that the background installation of packages disturbs that creation of new entries?
      When i added, reinstallation was running in background.

    Snap is (i386) built on Thu Jan 20 20:59:52 EST 2011.

    edit: Tried when the updates where finished: Now new aliasses and rules don't disappear after creation. Its the auto-update in background!

    1. Umlauts and other special chars in description fields of aliasses and rules are not accepted. Some of them disappear, others spit out errors, complaining "Not allowed…"

    2. With this snap from today i see some strange new errors in my system-log:

    Jan 21 12:17:25 check_reload_status: syncing firewall
    Jan 21 12:17:23 php: : WARNING! Configuration written on bootup. This can cause stray openvpn and load balancing items in config.xml
    Jan 21 12:16:28 check_reload_status: syncing firewall
    Jan 21 12:16:26 php: : WARNING! Configuration written on bootup. This can cause stray openvpn and load balancing items in config.xml
    Jan 21 12:16:21 php: : Beginning package installation for squid3.
    Jan 21 12:16:17 check_reload_status: syncing firewall
    Jan 21 12:16:15 php: : WARNING! Configuration written on bootup. This can cause stray openvpn and load balancing items in config.xml

    Anyone having the same happenings?


  • Rebel Alliance Developer Netgate

    1. Reinstalling packages will write (and re-read) the config multiple times. It wouldn't be a good idea to be doing anything in the GUI that you intend to keep while packages are being reinstalled.

    2. There are still some places that cannot handle special characters. I don't think they are valid for use in pf alias/table names, usually if we reject them in the GUI it's because they really cannot be used. The description fields should handle them though. It would help to know exactly which fields are exhibiting which behavior, especially if they just disappear.

    3. That warning was always there but the check that showed it was invalid. I fixed the check while I was trying to track down another package reinstall issue, but it may be benign these days.



    1. Thats ok, so the reinstall took some long time and i didn't realize. When it was done "visible", it was ok. It would be fine, if at the dashboard i could see this reinstall-action in some way. A simple info. If thats possible.

    2. I didn't refer to the alias-names, only description. And we have some umlauts within our language. Sorry… ;)

    3. Ah. Ok.

    Thanks for your answer!


  • Rebel Alliance Developer Netgate

    We discussed earlier today putting up a notice in the GUI that the packages were being reinstalled, sort of a warning not to touch anything until it settled. I'll probably add that in next week sometime if nobody does it before me.


  • Rebel Alliance Developer Netgate

    It should be notifying now in the GUI when the packages are being reinstalled in the background.

    As for the aliases and special characters, I still need a specific example of exactly which fields are doing what with the umlauts and I can take another look.



  • yes, confirmed: I get the harddisk and "Update in progress". Very nice.


Locked