Pfsense is not able to boot



  • Today i updated my pfsense. After reboot i get the message upgrade in progress. After a few minutes the pfsense seems to work. But then i noticed that the openvpn services are not started. So i tried to start them manually. I see that the services also didn't start with manually restart. After that i tried to reboot the server. I waited and waited that the server came up again. Then i went to the server an look at the monitor and see that the server reboots in a loop. Before the reboot came there was an error that init was not found. Ok i know this is a very big problem.
    Is there any way to get the pfsense to work or is a new install necessary? If a must reinstall the system how can i save the actual config?
    I hope anybody can hep me.



  • Best case scenario, you made a recent backup of your config, or somebody here can help you.

    Worst case scenario, you should be able to mount your drive in a working system and extract the config that way. In fact, I think the installer CD will specifically give you that option if you boot from it.

    As for the attempted rescue, can you provide a picture or capture of the console right before the reboot?



  • A backup exists but is about 2 month old. I think there should be not so many changes but i am not sure.
    I will make a photo of the error.



  • so here is the foto

    Uploaded with ImageShack.us



  • I tried to boot a linux live system and mount the bsd partition. I think that the partition is damaged. I can't mount the partition.

    i used folliwing syntax: mount -r -t ufs -o ufstype=ufs2 device mountpoint

    i get the message wrong magic number



  • you should boot a freebsd, not linux. Thats the wrong system to repair that partition.



  • igor, if it is ufs module, linux should work fine.  i think he may be right.


  • Rebel Alliance Developer Netgate

    Even if Linux could properly read/write ufs, pfSense uses ufs2, and I doubt Linux could fsck the partition if needed.

    Sad to say but it looks like your partition is corrupted (bad disk?). You could boot from a pfSense live cd, drop to a shell prompt (don't reinstall) and run:

    fsck -y /dev/da0s1a

    That might be able to find/fix something. If not, you'll probably have to reinstall and restore a configuration backup.



  • I have mounted a pfsense disk in Linux before, and it's not simple. First, you have to pass the right UFS type in your mount command, and there don't appear to be any obvious hints in Linux as to which type that should be. It was trial and error, as I recall.

    Then when you do get it mounted, chances are good it will be read-only, as the standard Ubuntu kernel, (and probably other distros) doesn't include UFS write support, so you end up compiling your own kernel. I believe I actually did this at one point, but I don't recall the level of success that I eventually obtained with it. It's probably less trouble to just roll up a BSD VM somewhere.


  • Rebel Alliance Developer Netgate

    Yeah, the effort involved is not worth it to access ufs rw in Linux. It's far too easy these days to setup a VM and pass a disk to it, or grab a spare box and toss on FreeBSD.



  • i reinstalled pfsense now

    the only problem that the dhcp clients loose there ip and i see an error in the logs

    dhcpd: send_packet: Host is down

    and sometimes but not everytime the server freezes

    i found this: http://lists.freebsd.org/pipermail/freebsd-bugs/2010-January/038270.html


Locked