Siproxd really version 7.2?



  • I installed the siproxd package on my pfsense 1.2.3 release a couple of weeks ago and so far have seen a couple of issues.
    The package says its 7.2, but when the siproxd daemon loads and the siproxd.conf says to load the logging plugin, siproxd throws up the error: "siproxd[861]: readconf.c:309 ERROR:unknown keyword in config file, line:"plugindir=/usr/local/lib/siproxd/""
    and also
    "siproxd[861]: readconf.c:309 ERROR:unknown keyword in config file, line:"load_plugin=plugin_logcall.la"" which makes me believe the package is not 7.2 but an earlier version that does not support plugins yet.

    Also, I see alot of rtp stream issues, which maybe fixed in newer versions:
    "siproxd[1435]: rtpproxy_relay.c:398 INFO:RTP stream f8e34a2e-83d4c467@192.168.0.221 (media=0) has expired"

    If the package maintainer sees this, please update the package to 8.0 the current version if possible.



  • After more digging and looking in my backup.xml file, here is the filename of the package "siproxd-0.7.0_1.tbz", which also suggests the package is 7.0, which does not match the siproxd gui setup, the gui setup has options that don't yet exist in version 7.0 of siproxd.

    Hello siproxd maintainer, are you around?



  • I have the same error message, I have two sites running pfsense and both have siproxd but even though the versions of siproxd are the same the user interface and options are all different. I currently uninstalled siproxd and went to a backup.xml file until i can figure out what is going on. I'm trying to config fonality  voip at a remote site and we are getting some loss when the caller at the site speaks. They can hear us just fine. Are you having any of these issues?

    Thanks,

    Al



  • @albert.hang:

    I have the same error message, I have two sites running pfsense and both have siproxd but even though the versions of siproxd are the same the user interface and options are all different. I currently uninstalled siproxd and went to a backup.xml file until i can figure out what is going on. I'm trying to config fonality  voip at a remote site and we are getting some loss when the caller at the site speaks. They can hear us just fine. Are you having any of these issues?

    There are many things to consider, the pfsense firewall config, whether to use siproxd or not, and the config on the phones themselves, so my combination of settings may not (and probably will not) work for your setup.  You just have to tweak each thing until you get a working configuration.  Doing a tcpdump on your pfsense box while watching your sip traffic will give clues as to what needs to be configured or changed.


  • Rebel Alliance Developer Netgate

    Looks like we didn't have a siproxd 0.8 binary up for 1.2.3 (but we did on 2.0)

    Should be fixed now.



  • Hey, just wanted to post an update for anyone with similar issues. Basically we made a lot of mistakes and we had an issue with siprox and our firewall rules, we bit the bullet and paid for pfsense support. Jim and Chris were able to fix the issue in short order and I would have to say the support is worth every penny. I also learned a lot about pfsense. thanks cgill27 for your comments too and good luck with your setup.


Log in to reply