Cannot remove squidguard from pfsense 1.2.3



  • I've tried to remove the package squidguard and reinstall full reinstall xml

    Im always getting this message

    Warning: delete_package(/usr/local/pkg/squidguard.inc): failed to open stream: No such file or directory in /etc/inc/pkg-utils.inc on line 754 Fatal error: delete_package(): Failed opening required '/usr/local/pkg/squidguard.inc' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg') in /etc/inc/pkg-utils.inc on line 754

    I've tried to take another squidguard.inc from another working pfsense installation and after that the error is

    Fatal error: Call to undefined function: squidguard_deinstall_command() in /etc/inc/pkg-utils.inc(520) : eval()'d code on line 1

    anybody can help me ? dont want reinstall all?

    Version: squidGuard 1.3-2

    Thanks,


  • Rebel Alliance Developer Netgate

    You can either edit squidguard out of the config, or try:

    fetch -o /usr/local/pkg/squidguard.inc http://www.pfsense.org/packages/config/squidGuard/squidguard.inc
    

    And then try again.



  • ok i've tried after getting the file

    I get the error about squidguard_configurator.inc is missing

    I do

    fetch -o /usr/local/pkg/squidguard_configurator.inc http://www.pfsense.org/packages/config/squidGuard/squidguard_configurator.inc

    after that if I try to uninstaller or reinstall the packages im getting this message

    Fatal error: Call to undefined function: sg_init() in /usr/local/pkg/squidguard.inc on line 92

    thanks Jimp


  • Rebel Alliance Developer Netgate

    Perhaps this:

    rm /usr/local/pkg/squidguard*
    fetch -o /usr/local/pkg/squidguard.inc http://www.pfsense.org/packages/config/squidGuard/squidguard.inc
    fetch -o /usr/local/pkg/squidguard_configurator.inc http://www.pfsense.org/packages/config/squidGuard/squidguard_configurator.inc
    

    And then remove it from the GUI by hitting the 'x'.

    That function is in squidguard_configurator.inc, if it's there it should be working, though doing the rm first will clear out all of the package's xml files as well, which may help.



  • working thanks a lot! :)


Locked