PPPoE connection terminated every 10 minutes



  • From the system log:

    Jan 26 17:45:41 husky mpd: [pppoe] IFACE: Up event
    Jan 26 17:45:46 husky check_reload_status: rc.newwanip starting
    Jan 26 17:45:46 husky php: : Informational: rc.newwanip is starting wan.
    Jan 26 17:45:46 husky php: : rc.newwanip working with (IP address: xxx.xxx.xxx.xxx) (interface: wan) (interface real: ng0).
    Jan 26 17:45:51 husky php: : Informational: DHClient spawned /etc/rc.newwanip and the new ip is wan - xxx.xxx.xxx.xxx.
    Jan 26 17:45:52 husky php: : Creating rrd update script
    Jan 26 17:45:52 husky php: : Configuring slbd
    Jan 26 17:45:52 husky check_reload_status: reloading filter
    Jan 26 17:45:53 husky check_reload_status: updating dyndns
    Jan 26 17:55:41 husky mpd: [pppoe] LCP: rec'd Terminate Request #246 link 0 (Opened)
    Jan 26 17:55:41 husky mpd: [pppoe] LCP: state change Opened –> Stopping
    Jan 26 17:55:41 husky mpd: [pppoe] LCP: phase shift NETWORK –> TERMINATE
    Jan 26 17:55:41 husky mpd: [pppoe] setting interface ng0 MTU to 1500 bytes
    Jan 26 17:55:41 husky mpd: [pppoe] up: 0 links, total bandwidth 9600 bps
    Jan 26 17:55:41 husky mpd: [pppoe] IPCP: Down event
    Jan 26 17:55:41 husky mpd: [pppoe] IPCP: state change Opened –> Starting
    Jan 26 17:55:41 husky mpd: [pppoe] IPCP: LayerDown
    Jan 26 17:55:41 husky mpd: [pppoe] IFACE: Down event
    Jan 26 17:55:41 husky mpd: [pppoe] exec: /sbin/route delete 0.0.0.0 xxx.xxx.xxx.xxx
    Jan 26 17:55:41 husky mpd: [pppoe] exec: /sbin/route delete xxx.xxx.xxx.xxx -iface lo0
    Jan 26 17:55:41 husky mpd: [pppoe] exec: /sbin/ifconfig ng0 down delete -link0
    Jan 26 17:55:41 husky mpd: [pppoe] LCP: SendTerminateAck #25
    Jan 26 17:55:41 husky mpd: [pppoe] LCP: LayerDown
    Jan 26 17:55:43 husky mpd: [pppoe] LCP: state change Stopping –> Stopped
    Jan 26 17:55:43 husky mpd: [pppoe] LCP: phase shift TERMINATE –> ESTABLISH
    Jan 26 17:55:43 husky mpd: [pppoe] LCP: LayerFinish
    Jan 26 17:55:43 husky mpd: [pppoe] device: CLOSE event in state UP
    Jan 26 17:55:43 husky mpd: [pppoe] device is now in state CLOSING
    Jan 26 17:55:43 husky mpd: [pppoe] device: DOWN event in state CLOSING
    Jan 26 17:55:43 husky mpd: [pppoe] device is now in state DOWN
    Jan 26 17:55:43 husky mpd: [pppoe] link: DOWN event
    Jan 26 17:55:43 husky mpd: [pppoe] LCP: Down event
    Jan 26 17:55:43 husky mpd: [pppoe] LCP: state change Stopped –> Starting
    Jan 26 17:55:43 husky mpd: [pppoe] LCP: phase shift ESTABLISH –> DEAD
    Jan 26 17:55:43 husky mpd: [pppoe] LCP: LayerStart
    Jan 26 17:55:43 husky mpd: [pppoe] device: OPEN event in state DOWN
    Jan 26 17:55:43 husky mpd: [pppoe] pausing 6 seconds before open
    Jan 26 17:55:43 husky mpd: [pppoe] device is now in state DOWN
    Jan 26 17:55:43 husky mpd: [pppoe] device: OPEN event in state DOWN
    Jan 26 17:55:43 husky mpd: [pppoe] device is now in state DOWN
    Jan 26 17:55:44 husky mpd: [pppoe] closing link "pppoe"…
    Jan 26 17:55:44 husky mpd: [pppoe] link: CLOSE event
    Jan 26 17:55:44 husky mpd: [pppoe] LCP: Close event
    Jan 26 17:55:44 husky mpd: [pppoe] LCP: state change Starting –> Initial
    Jan 26 17:55:44 husky mpd: [pppoe] LCP: LayerFinish
    Jan 26 17:55:44 husky mpd: [pppoe] device: CLOSE event in state DOWN
    Jan 26 17:55:44 husky mpd: [pppoe] device is now in state DOWN
    Jan 26 17:55:47 husky mpd: [pppoe] opening link "pppoe"…
    Jan 26 17:55:47 husky mpd: [pppoe] link: OPEN event
    Jan 26 17:55:47 husky mpd: [pppoe] LCP: Open event
    Jan 26 17:55:47 husky mpd: [pppoe] LCP: state change Initial –> Starting
    Jan 26 17:55:47 husky mpd: [pppoe] LCP: LayerStart
    Jan 26 17:55:47 husky mpd: [pppoe] device: OPEN event in state DOWN
    Jan 26 17:55:47 husky mpd: [pppoe] pausing 2 seconds before open
    Jan 26 17:55:47 husky mpd: [pppoe] device is now in state DOWN
    Jan 26 17:55:49 husky mpd: [pppoe] device: OPEN event in state DOWN
    Jan 26 17:55:49 husky mpd: [pppoe] device is now in state OPENING
    Jan 26 17:55:49 husky mpd: [pppoe] rec'd ACNAME "XXXXXX"
    Jan 26 17:55:49 husky mpd: [pppoe] PPPoE connection successful
    Jan 26 17:55:49 husky mpd: [pppoe] device: UP event in state OPENING
    Jan 26 17:55:49 husky mpd: [pppoe] device is now in state UP
    Jan 26 17:55:49 husky mpd: [pppoe] link: UP event
    Jan 26 17:55:49 husky mpd: [pppoe] link: origination is local
    Jan 26 17:55:49 husky mpd: [pppoe] LCP: Up event
    Jan 26 17:55:49 husky mpd: [pppoe] LCP: state change Starting –> Req-Sent
    Jan 26 17:55:49 husky mpd: [pppoe] LCP: phase shift DEAD –> ESTABLISH
    Jan 26 17:55:49 husky mpd: [pppoe] LCP: SendConfigReq #26

    My ISP requires us to pppoe over VLAN tag 500. The connection stops responding and terminated after approx every 10 minutes then it reconnects. How do i solve this problem? Thanks in advance


  • Rebel Alliance Developer Netgate

    "LCP: rec'd Terminate Request" means it received a terminate request from the other end (meaning your ISP)

    So it appears something on your ISP's network is forcing you to disconnect every 10 minutes. Have you talked to them?



  • i am experiencing the same issue as anonymouz as well.. getting disconnected every 8 minutes or so.. I believe we're on the same ISP too since it is also tagged on VLAN500..

    i have no idea what is pfsense doing that causes the ISP to disconnect my connection, when I used ClearOS and initiated a ping it went on for an entire day.  ???



  • It seems some of us suspect the problem comes from echo requests/replies not present and is killing the connection. And yes calvinz we are both on the same ISP :)



  • You must alert your internet service provider if the problem persists as I do not see any reason why your connection would disconnect from time to time.

    I know I am from a different ISP but with this setup, I really find the connection at its most stable against other connections. I also think that the terminate protocol was coming from your ISP so contact support to know what the problem is.


Log in to reply